Injector errors in log for M4

Discussion and support for MoTeC's earlier generation ECUs

Injector errors in log for M4

Postby stownsen914 on Mon Jul 23, 2018 1:14 pm

I recently got a Porsche 968 motor that sat for many years running again. It has the same M4 and map as when it last ran years ago. After a shakedown run at the track a couple weeks ago, I downloaded the logs and found injector errors. In approx. 4.5 minutes of logs, I see a few seconds worth of errors for each injector (injector 4 had the most at 18 seconds worth). The errors seem spread out during the 4.5 minutes. There are also a couple seconds worth of Sync errors in the logs. The EMP diagnostics screen shows OK for each injector. The engine seemed to run fine from a "seat of the pants" standpoint. The injectors are older Bosch units that I had rebuilt while the engine was being rebuilt. I saved the logs from this engine's last run years ago before the car was put in storage, and there aren't any injector errors.

Should I be concerned about injector errors in the logs? Thanks.

Scott
stownsen914
 
Posts: 15
Joined: Sat Dec 20, 2014 8:34 am
Location: Ossining, NY

Re: Injector errors in log for M4

Postby stownsen914 on Tue Jul 24, 2018 9:30 pm

I checked the EMP diagnostics again, and it reads OK for all 4 injectors. I also did the injector test for about 30 seconds and didn't notice any issues. And then re-downloaded the logs to see if any new errors show in the logs - there aren't any. This is of course at low duty cycle. Does the engine need to be running to properly test this?
stownsen914
 
Posts: 15
Joined: Sat Dec 20, 2014 8:34 am
Location: Ossining, NY

Re: Injector errors in log for M4

Postby SprinterTRD on Wed Jul 25, 2018 9:53 am

The only time logging starts is when the engine is running.

If it is a old loom then replace the injector connector pins also have a look at drawing Z05
SprinterTRD
Pro User
 
Posts: 317
Joined: Wed Jul 16, 2008 8:24 am

Re: Injector errors in log for M4

Postby stownsen914 on Wed Jul 25, 2018 10:35 pm

Thank you SprinterTRD. I poked around on the Motec site and googled, and can't find drawing Z05. Where should I look for that?
stownsen914
 
Posts: 15
Joined: Sat Dec 20, 2014 8:34 am
Location: Ossining, NY

Re: Injector errors in log for M4

Postby David Ferguson on Thu Jul 26, 2018 1:31 am

Here is the Z05 drawing:
Attachments
MoTeC USA Z05.pdf
Crimping Details for 36-pin connector
(69.1 KiB) Downloaded 216 times
David Ferguson
Veracity Racing Data
Check out Shift RPM - https://shiftrpm.veracitydata.com
David Ferguson
Pro User
 
Posts: 800
Joined: Fri Nov 07, 2008 1:45 am
Location: Paso Robles, California


Return to M4 and M48 ECUs (including M2R and MLS variants)

Who is online

Users browsing this forum: No registered users and 5 guests