Quick Lambda and Closed Loop from a 5 wire?

Discussion and support for MoTeC's earlier generation ECUs

Quick Lambda and Closed Loop from a 5 wire?

Postby Flow on Tue Nov 26, 2019 2:05 pm

Hi folks,

Has anyone been able to get closed loop or quick lambda working on an M4 with an analogue output from a third party 5 wire sensor controller?
Flow
 
Posts: 14
Joined: Thu Aug 15, 2019 6:21 am

Re: Quick Lambda and Closed Loop from a 5 wire?

Postby AdamW on Wed Nov 27, 2019 8:45 pm

Yes, it works fine. From memory you need the advanced options to access the user defined calibration and the other gotcha is the lambda input can only take a max of 1.2V, rather than the 5V that the help file states.
Motorsport Electronics Ltd.
AdamW
Pro User
 
Posts: 265
Joined: Wed Nov 16, 2011 9:08 am

Re: Quick Lambda and Closed Loop from a 5 wire?

Postby Flow on Fri Nov 29, 2019 5:33 am

Thanks Adam!

I have asked AEM if is it possible to configure the 0-5V output on the 30-0300 to 0-1V as per the 30-4100. If not I assume a voltage divider will do the trick.
Flow
 
Posts: 14
Joined: Thu Aug 15, 2019 6:21 am

Re: Quick Lambda and Closed Loop from a 5 wire?

Postby AdamW on Fri Nov 29, 2019 11:05 am

A bit more info in this thread: viewtopic.php?f=10&t=3442
On my one I used a 5:1 voltage divider from memory made up of a 12K & 3K resistor.
Motorsport Electronics Ltd.
AdamW
Pro User
 
Posts: 265
Joined: Wed Nov 16, 2011 9:08 am

Re: Quick Lambda and Closed Loop from a 5 wire?

Postby Flow on Mon Dec 02, 2019 6:27 pm

Great info Adam, thank you!
Flow
 
Posts: 14
Joined: Thu Aug 15, 2019 6:21 am


Return to M4 and M48 ECUs (including M2R and MLS variants)

Who is online

Users browsing this forum: No registered users and 9 guests