extra unwanted fuel

Forum for general discussions on engine tuning, not specific to a particular motec ECU

extra unwanted fuel

Postby Cropduster on Mon Apr 08, 2019 8:33 pm

I have an issue with tuning my bike, it runs an M400 and it starts and runs fine, idles well and is responsive and runs clean with an acceptable air fuel ratio, until it's fully warm that is.
While it's cold it starts fine, as it warms it's fine but once it reaches operating temperature it starts to load up and then of course runs rough, stumbles and eventually stalls or needs a big rev to clear it before going through the cycle again.

Can anyone tell me where to look, would the accelerator enrichment area be causing this? i'm kinda lost and can't seem to find any other examples of my problem for reference.
Thanks.
Cropduster
 
Posts: 9
Joined: Wed Mar 01, 2017 2:16 pm

Re: extra unwanted fuel

Postby David Ferguson on Tue Apr 09, 2019 2:08 am

Mostly likely you need to properly tune the Adjust->Fuel->Compensations->Engine Temp Comp. Normally this table would add 20-50% more fuel at low temperature, and taper to zero near the normal operating temperature.
David Ferguson
Veracity Racing Data
Check out Shift RPM - https://shiftrpm.veracitydata.com
David Ferguson
Pro User
 
Posts: 801
Joined: Fri Nov 07, 2008 1:45 am
Location: Paso Robles, California

Re: extra unwanted fuel

Postby Cropduster on Tue Apr 09, 2019 9:10 am

Thanks David, i'll go check it out and report back.
Cropduster
 
Posts: 9
Joined: Wed Mar 01, 2017 2:16 pm

Re: extra unwanted fuel

Postby Cropduster on Tue Apr 09, 2019 10:40 pm

that table looks ok, in fact they all do, aside from the cold start compensation i only have 1.9% additional in ET comp and 1.6% in map comp.

The issues i'm having now seem to be more related to a gremlin, a failing sensor that gets worse with full operating temp and some heat say from a hot engine, it has a strange injector cut that cycles on and off, only when at full operating temp and at about 3% throttle, as well as that once hot if i give it a rev it just dies, won't settle into an idle at all which it does no problem when cold or warming up. To combat that i've added an extra 10 degrees of timing at the rpm behind where i want it to idle.
I'll see if that helps once i swap out the crank rotation sensors in an attempt to isolate the cutting out issue.
Cropduster
 
Posts: 9
Joined: Wed Mar 01, 2017 2:16 pm

Re: extra unwanted fuel

Postby Cropduster on Wed Apr 10, 2019 2:19 pm

Ignore all that.....

I had a funky meeting in the fuel overrun cutoff window, i've zeroed that out and my strange behaviour and cutting out issue is gone, just need to map it properly now......
Thanks for the input David.
Cheers
Cropduster
 
Posts: 9
Joined: Wed Mar 01, 2017 2:16 pm


Return to Tuning discussions

Who is online

Users browsing this forum: No registered users and 4 guests