Jenvey ETA2 Servo (DBW) issues

Discussion and Support for MoTeC's M1 series ECUs

Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Tue Apr 27, 2021 12:08 pm

I've been battling a very annoying DBW issue. When I power up the ECU (M150), sometimes it generates an Aim Tracking error. This happens after a previous session where the car does a significant number of laps, returns to the paddock, and sits for a half hour or so. I think it’s heat-soak-related, but I don’t have any way to provide data about what the ECU actually sees.

If I wait a bit (15 minutes or so), then recycle the ECU, sometimes the condition clears, then I'm good to go until the next time.

Is there any way to dig into this a bit more? I'm looking for something I can show Jenvey.
Attachments
fullsizeoutput_a75.jpeg
fullsizeoutput_a75.jpeg (248.73 KiB) Viewed 1848 times
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby SDean on Tue Apr 27, 2021 2:33 pm

Hi,

I would be logging the Main and Tracking voltages for both banks, and comparing them when the engine is cold and hot (when you are getting the Aim Tracking Fault).

If the M1 is aiming for 2% at startup, and the servos cannot drive to that position, then you will get the Aim Tracking Fault reported. If you start with a slightly higher throttle position, does it do the same thing? Namely, is the throttle stop, or something else, physically stopping the plates from closing further?
Stephen Dean
MoTeC Research Centre Melbourne, Australia
User avatar
SDean
Site Admin
 
Posts: 972
Joined: Tue Dec 02, 2014 9:29 am
Location: Melbourne

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Wed Apr 28, 2021 4:37 am

Thanks Stephen. I'll check the logging of those voltages and look carefully at them during failure vs success. The throttle stop notion occurred to me as well, but I don't think that's it. But I'll look at that again.
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby Salasko Racing on Fri Apr 30, 2021 2:15 am

I've fought these Jenvey DBW servos quite a bit. They seem to be pretty crappy motors compared to literally everything else I've used.

My feed forward is

0 - 0
1 - 10
100 - 21

P 45
I 15 -25 clamp
D 70
Freq 8000

It's not perfect but no errors anymore.
Salasko Racing
 
Posts: 17
Joined: Thu Nov 19, 2015 8:59 am

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Tue May 04, 2021 12:00 am

Salasko: that's great information. I'll compare to my tune, and give that a try. Is there another servo that's similar in size that you'd recommend over the Jenvey?
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby greenamex2 on Tue May 04, 2021 6:24 pm

How many throttle bodies are you opening?

If it is 6 Jenvey bodies, happy to share my current settings.
Motec CDL3+M130+LTCD+MDD+PDM15+PDM16M
Nissan VQ30DE fitted to an AM Sportscars EX2 with a Hewland HP 2000
greenamex2
 
Posts: 293
Joined: Fri Sep 12, 2014 6:06 am
Location: England

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Wed May 05, 2021 3:54 am

I've got dual throttle servos, each driving 4 throttles, thanks!
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby greenamex2 on Wed May 05, 2021 4:13 am

parsonsj wrote:I've got dual throttle servos, each driving 4 throttles, thanks!


You tried the 4 cylinder settings from Jenvey on each bank?
Motec CDL3+M130+LTCD+MDD+PDM15+PDM16M
Nissan VQ30DE fitted to an AM Sportscars EX2 with a Hewland HP 2000
greenamex2
 
Posts: 293
Joined: Fri Sep 12, 2014 6:06 am
Location: England

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Wed May 05, 2021 6:49 am

You tried the 4 cylinder settings from Jenvey on each bank?


Yes -- if you mean the datasheet Jenvey have on their website. In fact, I've never tried any other setting other than that.
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Wed May 05, 2021 6:57 am

Checking my calibration: It's the same as Salasko's above except for the feed forward table. Mine is at
0 0
1 8, rather than 10
100 21
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Next

Return to M1 ECUs

Who is online

Users browsing this forum: No registered users and 6 guests