Jenvey ETA2 Servo (DBW) issues

Discussion and Support for MoTeC's M1 series ECUs

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Wed May 05, 2021 7:12 am

Just looking at Jenvey's website... and the datasheet I used has been removed (I have a copy). There's one for the Ford Coyote package with a markedly different setup. This has all happened within the past couple of months.

Seems like I need my own characterization. :shock:
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Tue May 11, 2021 11:26 am

I experimented today. I got out my heat gun, turned the car on, and did some throttle testing. As expected all was well. Then while the car was on, I heated the Bank 1 Servo to 100*C, and turned the ECU off and back on. And Bank 1 generated a tracking fault!

I tried to do the same with Bank 2, but it wouldn't fail even at 120*C. I had a spare servo, so I installed it on Bank 1 and tried without success to recreate the problem. Perhaps the whole deal was a bad servo, or at least a heat intolerant servo.

More to come: I'm on track this weekend, and we'll see how it goes.
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby parsonsj on Mon May 17, 2021 11:02 am

Track weekend at Sebring Raceway here in Florida. A sunny and hot weekend, temps in the low 30s (C). I was on track for every session because I didn't have a single throttle servo tracking fault. Both were rock solid all weekend, and I went to some trouble to make them fail.

It was just a faulty servo all along. Not the configuration, not the ECU interface, not the wiring, not the way the servo was mounted, not anything to do with the linkage. Just. a. faulty. servo.
parsonsj
 
Posts: 49
Joined: Thu Oct 04, 2018 1:49 pm

Re: Jenvey ETA2 Servo (DBW) issues

Postby greenamex2 on Mon May 17, 2021 5:23 pm

Well done for sticking with it and finally getting it sorted
Motec CDL3+M130+LTCD+MDD+PDM15+PDM16M
Nissan VQ30DE fitted to an AM Sportscars EX2 with a Hewland HP 2000
greenamex2
 
Posts: 293
Joined: Fri Sep 12, 2014 6:06 am
Location: England

Previous

Return to M1 ECUs

Who is online

Users browsing this forum: No registered users and 5 guests