C125 Dash incorrect figures

information about how to make an ECU (MoTeC or non MoTeC) work with a MoTeC dash or data logger

C125 Dash incorrect figures

Postby trucker on Sat Nov 28, 2020 6:37 am

Hello forum I have a M400 ecu with a C125 color dash. The oil pressure, fuel pressure, & engine temp info that is displayed on the dash are wrong. Fuel pressure displays as 5.423, oil pressure 2.74 & engine temp at 380.66. Can anybody guide me thru how to calibrate them so they show the correct values in PSI? Thanks In advance.
trucker
 
Posts: 11
Joined: Sun Sep 30, 2012 4:53 am

Re: C125 Dash incorrect figures

Postby David Ferguson on Sat Nov 28, 2020 12:45 pm

Your dealer should be most helpful.
Have you calibrated the units in the ECU to display in kPa? You need to do that so the data transmitted is in the right format for the CAN templates provided with the C125. Then you need to make sure the display units in the c125 are in. PSI.
David Ferguson
Veracity Racing Data
Check out Shift RPM - https://shiftrpm.veracitydata.com
David Ferguson
Pro User
 
Posts: 864
Joined: Fri Nov 07, 2008 1:45 am
Location: Paso Robles, California

Re: C125 Dash incorrect figures

Postby SDean on Mon Nov 30, 2020 8:06 am

Hi,

As Dave said, the ECU needs to be calibrated with the sensors in kPa so that the Dash receives the correct information. Currently you have the conversion being applied twice to the data, once in the ECU, and then again in the Dash.
Stephen Dean
MoTeC Research Centre Melbourne, Australia
User avatar
SDean
Site Admin
 
Posts: 822
Joined: Tue Dec 02, 2014 9:29 am
Location: Melbourne


Return to ECU to Dash Comms

Who is online

Users browsing this forum: No registered users and 1 guest