Not receiving lambda trim from M1

D153, D175, C125, C127, C185 and C187 forum

Not receiving lambda trim from M1

Postby Doorev1200 on Fri Aug 14, 2020 9:07 am

So i have done a simulation in display creator and used a log file from i2 to simulate and see what channels come through. It turns out that i am not receiving fuel closed loop trim. Here is the background on my project:

Running a motec m1 plug and play kit for 2016 skidoo xs 1200. In m1 and in i2 i log " fuel closed loop control trim" and it moniters fine.
I am preparing to run a c127 dash and have loaded m1 general 0x640 and 0x650 version 3. In the list i can only choose between fuel closed loop ctl b1 trim and fuel closed loop ctl b2 trim. There is no " fuel closed loop control trim" listed like my pkg has. I made a display creator layout that ibam going to run and when i simulate off the i2 log file everything works and displays except for closed loop trim.

Is the problem the pkg because the channel is not called "fuel closed loop ctl b1 trim"? Or does the dbc file need to be updated to accept the skidoo channel "fuel closed loop control trim?

I havent received my dash yet to actually test in reality but so far i dont think the dash will be recieving the trim channel from the skidoo m1 pkg... any ideas or just wait for the dash to arrive and test?
Doorev1200
 
Posts: 27
Joined: Thu Jun 18, 2020 1:57 pm

Re: Not receiving lambda trim from M1

Postby adrian on Thu Aug 20, 2020 8:26 am

"Fuel Closed Loop Ctrl B1 Trim" is the channel you are after. The "...B2 Trim" in the template doesn't do anything.

The Dash template is just our generic "M1 General" template that includes everything sent out from all of our packages. Packages like the Skidoo will only send out the channels that actually apply so you will find some of the channels in the Dash template will just be zero.
adrian
MoTeC
 
Posts: 608
Joined: Mon Apr 13, 2015 4:16 pm

Re: Not receiving lambda trim from M1

Postby Doorev1200 on Thu Aug 20, 2020 12:09 pm

ok sounds good, dash is on the way so I will be able to verify soon. Thank you!
Doorev1200
 
Posts: 27
Joined: Thu Jun 18, 2020 1:57 pm

Re: Not receiving lambda trim from M1

Postby Doorev1200 on Fri Sep 25, 2020 6:07 am

I received my c127 and i can confirm that i am receiving lambda trim from my m1 skidoo pkg to c127. Thanks for the help.
Doorev1200
 
Posts: 27
Joined: Thu Jun 18, 2020 1:57 pm


Return to Colour displays

Who is online

Users browsing this forum: No registered users and 1 guest