Page 1 of 1

Lap Gain/loss user conditions

PostPosted: Sat Mar 20, 2021 6:25 am
by plohl
I was trying to set up a User condition with my C125 that could be used to trigger one of the shift lights when I have done a good sector.

I thought about using Split Time, but couldn't see how to compare this to the ref lap.

Then I tried to get it to work for just the lap just using the lap gain/loss final channel - I think I know what I did wrong with this logic - (pic 1).

I can't simulate lap times with the dash (please let me know if there is a way I can do this), would anyone be able to confirm if the following logic might work (pic 2);

Lap Gain/Loss Running < 0 and Split Time Updated

This should activate the channel when the split time is updated and the lap gain/loss running channel is less than 0 - meaning, for each sector I should be able to trigger a light to come up on the dash.

I have the off condition set so it should turn off at the next braking zone.

Make sense?

Image
Image

Re: Lap Gain/loss user conditions

PostPosted: Mon Mar 22, 2021 12:27 pm
by adrian
You can simulate laps by adding the 'Beacon' channel to the simulate page. If you are using GPS for your beacon set the ID to 1, otherwise set it to the correct ID. For splits, add another beacon and give it an ID of your main ID + 1.

Below is one way to do the lights (red slower, green faster). The time in the 'deactivate' condition is how long the LED will be on for.

Re: Lap Gain/loss user conditions

PostPosted: Mon Mar 22, 2021 2:06 pm
by plohl
Thanks Adrian, knowing how to simulate laps is going to be very handy!
I didn't even think to use the output channel for deactivation, a lot better than using brake pressure.