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1 INTRODUCTION

1.1 Purpose
From M1 System Version 01.04.00.0091, two new pieces of functionality are included:

1. Batch Fire Fuel Injection.
2. Updated Serial Communications which allows M130 ECUs (from hardware revision Q and above)

and M122 ECUs to transmit and receive serial communications.

1.2 Supported Packages
To enable these features the system version of the package must be V01.04.00.0091 or later. To check this:

● Open M1 Tune
● Open the desired package
● Select File > Override ECU System Version

If your system version is less than V01.04.0091, please contact your package developer. Their details can be
found in the summary section of the Firmware Help.

Developers who want to update their packages to take advantage of this new system can refer to the section
Updating Firmware Project in this document.

2 Batch Fire Fuel Injection

Prior to M1 System Version 01.04.00.0091 batch fire ignition for a distributor setup was only supported on
multi tooth reference modes with no camshaft synchronization. And fuel injection was only enabled once the
crankshaft reference and camshaft synchronization patterns were both locked (i.e Engine Speed Reference
States is Cycle Lock).

In this M1 System Version 01.04.00.0091 update, two new Engine Speed Reference States have been
added; Revolution Lock and Cylinder Lock. This enables fuel injection and ignition when only the
reference pattern is locked.

This allows for:
● faster starting with all Reference Modes
● starting the engine without a synchronization sensor on certain Reference Modes
● starting the engine with a faulty synchronization sensor on certain Reference Modes

Revolution Lock allows for wasted spark ignition and batch fire fuel injection. For this state, the reference
pattern must only repeat once per crankshaft revolution (i.e. missing tooth reference modes). In this state
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while the fuel injection is synchronously timed to the crankshaft, the timing could be offset by 360 degrees in
a 4-stroke cycle engine.

Cylinder Lock allows for batch fire injection along with ignition via a distributor. For this state the reference
pattern must only repeat once per cylinder (i.e multi tooth ref mode where the number of reference trigger
teeth over a full engine cycle is the same as the number of cylinders) and all cylinders share the same
ignition resource. While the fuel injection is synchronously timed to the crankshaft the timing could be offset
by a multiple of the Cycle duration / The Number of Cylinders.

This batch fire feature should not be used on direct injected engines as the offset fuel timing will lead to
irregular behaviour.

2.1 Operation
This function can be enabled or disabled by setting the Engine Speed Reference Start Mode to Batch Fire.
Setting this mode to Sequential will only allow fuel injection and ignition when both the crankshaft reference
pattern and camshaft synchronization pattern are locked (i.e Engine Speed Reference States is Cycle Lock).

When Engine Speed Reference Start Mode is set to Batch Fire and provided that the Engine Speed
Reference Mode matches the requirements (listed previously) the Engine Speed Reference State will go to
Revolution Lock or Cylinder Lock once the reference pattern has been locked, enabling batch fire fuel
injection and ignition. If the synchronisation pattern then locks to the reference pattern the Engine Speed
Reference State will go to Cycle lock and fuel and ignition will be synchronously delivered, based on the
engine cycle as well as the crankshaft position.

The image below shows a four stroke 36-2 ref pattern that is Revolution Locked. The fuel is injected once per
cycle (720 degrees) while the ignition outputs are fired every half cycle (360 degrees). While the ignition
timing occurs at the user specified angle the Fuel Timing could be offset by half a cycle (360 degrees in this
case).
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3 Serial Communications

The hardware and firmware for the M150, M190, M14x, M18x ECUs supports serial communications. The
M130 ECU hardware was updated to support serial communications at revision Q.

To check the ECU’s hardware revision:
● Connect to the M130 using M1 Tune
● Select Tools > Show Information

All M122 ECU’s support serial communications.

Changes made in system 01.04.00.0091 allow for serial communications to be added to the firmware for
M130 (Rev Q+) and the M122 ECUs. This system change affects all hardware variants as it restructures how
a serial port is used and configured.

3.1 Operation
The following resources can be used for serial communications. Pin numbering can be found in each specific
hardware’s documentation.

ECU Transmit Receive

M130 (rev Q+), M122 INJ_LS1, INJ_LS2 UDIG6, UDIG7

M150, M190, M14x, M18x RS232_TX, LIN RS232_RX, LIN

The M130 (rev Q+) and M122 serial ports are now multifunction pins. If these are selected to be a serial port
pin then they’re not available for use as a Udig or LS Out. The pins are removed from the resource list for
other Udig or LS Out resources. The wiring list is also populated showing the pins as serial ports.

Note that the Serial Port settings and channels (i.e. Baud Rate, Diagnostic, etc.) now reside in the individual
groups (i.e GPS, Bosch Wiper, etc.). The Baud Rate and Serial Port Resource need to be configured. Once
configured the serial communications will operate as normal.
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4 Updating Firmware Project

Follow these steps to update your M1 Build project so that Batch Fire Fuel Injection can be used in the
output Package.

1. Open M1 Build

2. Select Help > Check for Updates

3. Download and install the latest system and modules

4. Open the desired project

5. Select the Settings tab and in the System section, change Version to 01.04.00.0091 (or later).

6. Select the Modules tab
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7. To update the MoTeC Fuel module (if in use), right-click on the module and select Version

8. Set the Version and Build Number to V1.18.0001 (or later).

9. Repeat steps 7 and 8 to update the following modules (if in use)

a. MoTeC GPS module to V1.07.0021 (or later).
b. Bosch OE Integration module to V1.00.0031 (or later).
c. MoTeC Input module to V1.10.0036 (or later).

Note: depending on the previous version that was in use this may require additional
changes to the MoTeC Input class instances that are used throughout the project. See
MoTeC Input module help for more information on the changes between versions.

d. MoTeC Comms module to V1.10.0003 (or later).
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10. Select the Objects tab
Select Engine Speed Reference Start Mode
Set the Input Object to either a Parameter (so that it can be set by the user in M1 Tune), or a
Constant with the value Batch Fire. Refer to the enumeration help for details on each start mode.

11. Select the Engine Calculation Scheduled Function and add the following highlighted code
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12. Select the Warning Update Scheduled Function and add the following highlighted code

13. If Alternative Fuel is available

a. Select the Alternative Fuel Calculation Scheduled Function and remove the following
highlighted code.

Published Page 8 of 1415 Oct 2021



MoTeC Pty Ltd CTN0038 Batch Fire Fuel Injection and Serial Communications Updates

b. Select the Engine Calculation Scheduled Function and add the following highlighted
code:

14. Delete any existing Serial Port classes (e.g. RS232, LIN)

Published Page 9 of 1415 Oct 2021



MoTeC Pty Ltd CTN0038 Batch Fire Fuel Injection and Serial Communications Updates

15. Select the Warning Update Scheduled Function and replace the following highlighted code:

with this highlighted code:

Note: If the above code does not exist a Warning Mode RS232 Diagnostic parameter and
Warning Source enumerator will also need to be added.

16. To update any custom serial interfaces refer to the Custom Serial Interface section.

17. Validate and Build firmware

Once complete the package can then be used or uploaded to MoTeC online via the normal processes.

4.1 Custom Serial Interface
If the M1 Build project contains any other Custom Serial Interface, this section will provide additional
information required to update this.

In system 91 the following library functions were removed from the SDK:

● Serial.PortDiagnostic()
● Serial.PortInit()
● RS232Comms.Diagnostic()
● RS232Comms.Init()

While the following hardware classes were added to the SDK:
● Hardware - Digital Output - Serial Port
● Hardware - Digital Output - LIN Bus
● Hardware - Configuration - Serial Interface
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4.2 Serial Group moved to be device specific
Serial ports are typically dedicated to a single task. In the Build object tree, the serial port is now
grouped with the subsystem that is using it (rather than placed in a separate RS232 group). The
baud rate and diagnostics are configured in this subsystem. For example, the GPS baud rate is
now set in the GPS group in the new module. The subsystem is now also included in the name, for
example GPS Serial Port Baud, GPS Serial Port Diagnostic, etc.
For multiple serial devices in a project, multiple Serial Port classes can be added.
When the Port Resource is selected for one serial device, it blocks out the port for any other device
like any other pin resource.

4.3 Serial Interface Class
The M130 ECU (from hardware revision Q+) and the M122 ECU have several options available for port
configurations. This needs to be configured in the Hardware Configuration Serial Interface class.

The hardware has 2 identical ports with Rx and Tx that can be configured as RS232, Logic (RS232 TTL,
inverted polarity) and LIN.

The resource can be set to Serial N (Rx and Tx pins used), Serial N Rx (Rx pin only) and Serial N Tx (Tx pin
only) where ‘N’ is port number 1 or 2.

LIN always uses the both Rx and Tx pins, and requires some external circuitry or an external LIN driver chip
to function correctly. Contact MoTeC for LIN on M130 requirements.

IMPORTANT: The Hardware Configuration Serial class should not be used in projects with M150, M190,
M14x or M18x hardware as they have dedicated port pins.
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4.4 General Serial Port Use
For an RS232 device, add the Serial Port class to the device group and for LIN add the LIN Bus class to the
device group.

These only have Resource and Baud Rate value input objects to be configured. Channel feedback written by
the class are Diagnostic and Port number.
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Serial Port class properties example:

Typically the Resource object will be set to an external Resource Parameter placed at the top of the parent
group so that objects beneath are hidden when the resource is Not in Use. The Baud input object is
externally linked to a parameter.

Some restrictions now exist with the Baud parameter as the value input cannot be set to or linked to a
channel. Only a parameter or constant is valid. This value is used during bootup, before any Build code is
executed. This must be an Integer data type. The enumerated selection of Baud rates previously used is no
longer supported. It is recommended that the Port Baud value input is linked to an external Parameter so that
the help can list the common baud rates to enter. The Port Baud object within the class cannot have its help
edited.

Example object layout:

For M150, M190, M14x or M18x hardware the resource can be configured as a constant if only one serial
device exists in the project. This resource must be a parameter if multiple serial devices are supported. The
only selection is RS232 (port 0) for the Serial Port class, or LIN (port 1) for the LIN Bus class.

All other library functions for receiving or transmitting data are the same so changes to existing code in this
area are not required.

The one optional exception is the Serial.Transmit() and Serial.Receive() functions. These take a port number
argument and likely would have been hardcoded to 0 for RS232 and 1 for LIN in an existing project. That is
still fine, but the preferred way is now to set the Port argument to the Serial Port/LIN Bus channel that refers
to the Port number. This will always be 0 for RS232 and 1 for LIN, but if this same code was used for an
M130 the port numbers can be different, so it's good practice to use the Port channel value here. In an M130
you could for example set a LIN device to Serial 1 (port 0 using Udig 6 and LS Out 1) and an RS232 device
to Serial 2 (port 1 using Udig 7 and LS Out 2).

Example code:

Library.Serial.Transmit(h, This.Serial.Port, 4); // port based on the selected resource

4.5 Configuration of the Serial Interface class for M130 or M122 use
Typically this class would be grouped alongside the Serial Port/LIN Bus class and named Interface (as in the
above example). For the particular application, the configuration objects should be known and so can be set
as constants. This means the group will not appear in Tune.

Resource Object must be set as External and linked to the Serial Port/LIN Bus Resource object.

Mode selections are RS232 (RS232 levels), Logic (RS232 TTL levels, inverted polarity to the RS232 setting)
and LIN.

Threshold allows the Udig pin voltage trigger level to be set. Typically set to 2 V for all applications.
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4.6 Unsupported Hardware
The M130 prior to Rev Q hardware and all M170 ECUs do not support direct RS232 or LIN connection. A
package built for M130 Rev Q hardware can still be loaded and used in an older M130, but the serial ports
will not function. Likewise if this same code was built for an M170, it will compile but to prevent  confusion,
the serial port code should be removed from the Build project.

The Serial Port Diagnostic channel will report Hardware Error in this case and be seen as a fault in the
Status view in Tune.

Typical Serial Interface class properties for an RS232 device.

Published Page 14 of 1415 Oct 2021


