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1 INTRODUCTION 

With over 25 years of automotive knowledge, MoTeC has developed its next generation of ECUs 
with modern vehicles and controlled category racing at its core. Advances in technology have 
increased the demands on a vehicle's components, especially the ECU. This demand has 
reached a point where managing the intricate details of each installation become vital in 
providing the ultimate in performance. 

The M1 series was conceived to provide highly optimised targeted firmware for each unique 
installation. M1 is a platform where operational efficiency, advanced features and flexibility are 
its primary objectives. At its core, M1 provides the ability to develop a suite of flexible and 
tailored solutions (packages), making it ideal for any application (however complex) and 
category management. 

This new approach to engine management systems introduces new concepts, terminology and 
workflows - though much of this will be familiar to experienced Engine tuners. The M1 Tune 
software is the link between an M1 Packages and an M1 ECU. 

Some basic M1 concepts &amp; terminology will help you get started: 

• An M1 ECU is configured using a "Package" 

• An M1 Package is a collection of data for M1 firmware that primarily consists of: 

− A copy of the appropriate M1 firmware and help text 

− Calibration (tuning) data for the version of firmware 

− Data logging configuration 

− Workbooks (screen layouts for M1 Tune). 

• Each M1 Package is targeted to a specific M1 ECU model (M130, M150 etc.) 

• Each M1 Package includes help specific to its intended application 

• Packages can be upgraded to new versions of the firmware as they become available  

• M1 Tune is generic and can be used with any M1 Package or M1 ECU model 

M1 Tune has the same look and feel as MoTeC's i2 analysis software and is used for the 
configuration, analysis and calibration of M1 firmware. The application allows creation of 
customizable screen layouts that make engine calibration easier and faster. The ability to add 
and configure individual components allows Worksheets to be customised for each application. 
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Example Worksheet window showing a number of components  
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2 SYSTEM REQUIREMENTS 

The system requirements for effective use of the M1 Tune application are listed here.  

Operating system: Windows XP, Vista, Win7 (32 and 64 bit) 

Minimum screen resolution: 1024 x 768 

Recommended screen resolution: 1600 x 1200 or greater  

The higher the resolution the greater the screen layout 
options 

Communications port: Ethernet port 

Communication protocol: IPV6 
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3 INSTALLING THE M1 TUNE APPLICATION 

Important: If during installation, you are prompted to allow the M1 software to make changes 
to your PC, always allow; otherwise PC communications will not work. 

The M1 Tune software is available as a download from the MoTeC website at 
http://www.motec.com.au/software/latestreleases/  

To install the software, the user must have a high enough level of access for the installation 
software to be able to make the appropriate updates to the PC. This may require the software to 
be installed by an administrator.  

Once the software is installed, the M1 Tune icon is available from the desktop. Use this icon to 
start the M1 Tune software.  

3.1 CHECKING AND INSTALLING THE LATEST VERSION 

M1 Tune is constantly evolving. It is recommended to keep the software up-to-date. Check and 
update your version as follows.  

1. Select Help »About and take note the version you are using.  

2. Go to http://www.motec.com.au/software/latestreleases/ and check the latest release 
version.  

3. If a newer version is available, download and install the new version.  
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4 CONNECTING THE M1 ECU TO THE PC 

Important: If, during installation or application start-up, you are prompted to allow the M1 
software to make changes to your PC, always allow; otherwise PC 
communications will not work. 

The MoTeC M1 ECU uses an Ethernet connection for communication between the ECU and M1 
Tune. This ECU to PC connection uses a standard Ethernet cable, wiring and protocols.  

When producing M1 wiring, all Ethernet communications cables must comply with Category 5 
cable specifications. This includes wiring used to connect to the M1 ECU connector. MoTeC 
have panel mount category 5 Ethernet cables available that are suitable for this application.  

Note: It is recommended that Ethernet cables are wired as crossover from the ECU to 
the loom side socket. By doing this, a standard (non crossover) Ethernet cable can 
then be used for all communications between the ECU and the PC.  

4.1 PIN-OUT INFORMATION FOR ECU COMMUNICATIONS 

All M1 ECU to PC communications take place using the standard IPV6 
communications protocol via an Ethernet cable. 

 

The Ethernet connector pin-out is shown in the following table.  
 

Pin  Function  

1  Ethernet RX +  

2  Ethernet RX -  

3  Ethernet TX +  

6  Ethernet TX -  
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4.2 ESTABLISHING ECU COMMUNICATIONS 

The IPV6 protocol used by M1 Tune is the same method that is used in some internet 
communications. Accordingly, some anti-virus and firewall applications will treat M1 PC 
communications in the same way as other internet traffic. In most instances, this will have no 
effect, but some anti-virus applications may block the M1 to PC communication.  

To communicate from the PC to the ECU:  

1. Power up the ECU.  

2. Connect the Ethernet cable to the ECU and the PC.  

3. Start M1 Tune. See STARTING M1 TUNE. 

►The connected ECU should display in the Quick Launch fly-out or the ECU Select window.  

Example ECU Select window 

 

Note: If M1 Tune does not discover the ECU, see Resolving undiscovered ECU 
problems. 

4. Select the required ECU from the list of available ECUs.  

4.2.1 Resolving undiscovered ECU problems 

When the ECU starts communicating, you will see it appear automatically in the list of connected 
ECUs on the Quick Launch fly-out or the ECU Select window.  

If your ECU does not appear in the list, follow the steps below to resolve the cause of the 
communication problem.  

  



 

 User Manual

CONNECTING THE M1 ECU TO THE PC

 

Printed documents are not controlled Page 11 

1. Ethernet ports normally include LED indicator lights. Check if they are lit (they normally 
flicker, indicating data traffic on the cable) when the ECU is plugged in and powered ON. On 
some PCs and notebooks, rather than individual LEDs, the Ethernet connector is lit at the PC 
end. 

Example Ethernet port lights on a PC 

 

► If the ECU is powered ON and they stay OFF, it most likely indicates an Ethernet wiring 
issue.  

2. Where Ethernet wiring is confirmed as correct and there is still no communication:  

a) Temporarily disable, turn off, or uninstall any anti-virus applications.  

b) Close M1 Tune and ensure that the MoTeC Device Discovery service is also stopped. To 
check if MoTeC Device Discovery is running, display the active services as shown in the 
following image. If the MoTeC Device Discovery icon is shown (as circled below), 
right-click on it and select Exit. 

 

c) Restart M1 Tune and attempt to establish communications with the ECU. 

Note: If turning off or uninstalling your anti-virus or firewall fixes the problem, then 
your anti-virus or firewall application must be configured to allow the MoTeC 
ECU to communicate normally. 

If you have removed all anti-virus and firewall applications, and there is still no PC 
communication with the ECU, continue with the following steps. 

3. Ensure that the IPV6 communications protocol is installed on the PC (this is only an issue 
with some Windows XP software).  

a) Once any communication protocol issues are corrected, restart M1 Tune and attempt to 
establish communications with the ECU, see ESTABLISHING ECU COMMUNICATIONS. 

4. If all the above are addressed and there is still no communication, contact MoTeC support – 
http://www.motec.com.au/support/technicalsupportAU/  



 

 User Manual

STARTING M1 TUNE

 

Printed documents are not controlled Page 12 

5 STARTING M1 TUNE 

Important: If, during start-up, you are prompted to allow the M1 software to make changes to 
your PC, always allow; otherwise PC communications will not work. 

When the software is started, the Quick Launch window will fly out from the left hand side.  

From Quick Launch you can connect to an ECU, or open a Package offline. The Quick Launch 
images below provide examples “with” and “without” ECUs available for connection.  
 

This example indicates that there are available 
online ECUs for connection, as well as a 
number of recent Packages that are available 
to be opened offline.  

This example indicates that there are no ECUs 
that M1 Tune is able to connect to, but there 
are a number of recent Package that are 
available to be opened offline.  

  

 

Other options available from Quick Launch provide the ability to retrieve logged data (an M1 
ECU needs to be connected for this option to work), browse available ECUs, browse offline 
Packages, or help on M1 Tune.  
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6 OVERVIEW OF PACKAGES AND LAYOUTS 

Within the M1 environment, a Package is the name used to describe the complete set of data for 
an application.  

Layouts refer to how data is laid and displayed in the M1 Tune graphical user interface.  

Note: An M1 ECU can contain only one Package.  

If a new Package is sent to the ECU, it completely replaces all content that might have been part 
of a previous Package.  

A Package on an ECU connected to M1 Tune can be worked on directly (online). Packages 
stored on the PC are known as Offline Packages.  

6.1 PACKAGE CONTENTS 

A Package contains the following:  

• System Firmware  

• Tune Data (similar to an M800 Configuration)  

• Security information  

• A layout, that is, a Workspace containing base Workbooks and Worksheets, see LAYOUTS. 
Each M1 Tune Package contains three objects that are used for controlling the behaviour of 
the ECU; they are Channels, Parameters and Tables.  

 

Object  Package Segment  Definition  

Channels  Firmware  

A Channel is a system variable which is updated in the ECU 
firmware upon execution. Channels cannot be modified by 
the user. An example of a channel is a sensor value, such 
as throttle position.  

Parameters  
Firmware (for 
definition) Tune 
Data (for value)  

A defined value which may be altered by the user in M1 
Tune. These are the values that the end user modifies to 
setup things such as re/sync mode, gear ratios, RPM limit 
Etc.  

Tables  
Firmware (for 
definition) Tune 
Data (for value)  

Tables are a basic component of many control strategies 
such as fuel and ignition delivery, and gearbox control. The 
table is made up of a number of pre-configured axis types. 
From within M1 Tune these axes can be turned on and off, 
the axis sites changed, and the contents of tables modified. 
This is one of the main ways to configure the M1 ECU. The 
number of axes and the number of set points are defined in 
build, as are the input components and output units.  
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6.2 LAYOUTS 

A Package layout consists of:  

• A Workspace  

• Workbook(s)  

• Worksheets  

• Worksheet components  

Using a book analogy a Workspace is the library, Workbooks are the book and Worksheets are 
pages in the book. Worksheet components are the contents of a page.  

6.2.1 Workspace 

A Workspace is the name given to the entire collection of an M1 Tune layout, and is simply a file 
that contains the layout elements defined for a particular Workspace.  

Note: A Package can contain only one Workspace, see Default Package Layout. The 
Workspace (layout) provided as part of the Package cannot be changed. However, 
the data in the Package does not have to be displayed within the provided 
Workspace. Any number of Workspaces can be created in M1 Tune and saved to 
the PC. The Package data can be displayed in any Workspace selected by the user.  

User created Workspaces are populated with user configured and customised Workbooks, 
Worksheets and Worksheet components such as graphs, gauges, channel reports and alike. 
Commonly, this customisation is made to suit a particular application.  

Workspaces can be created, modified, exported and emailed from File »Workspaces 

Example of the need for a different Workspace 

A Package was created to work as a gearbox controller only, and not an engine management system. In 
this instance the Workspace containing the Workbooks, Worksheets and settings would only show the 
items to suit monitoring, setting up and calibrating a gearbox.  
When that same PC was used with the M1 ECU as an engine management system, the workbook layout, 
the worksheets, gauges and settings would need to be completely different. By creating a different 
Workspace, work on each of these two applications is easier.  

6.2.2 Workbooks 

Once a user created Workspace is available, it is possible to create new Workbooks. Workbooks 
can be used to separate different functions. An example of this would be to create a book called 
"Fuel", one called "Ignition", one called "Dyno tuning" and another called "Traction Control". Any 
number of these Workbooks can be created.  

Note: Keeping functional areas separate is the recommended method for using M1 
Tune. This allows easy identification of a functional area when work in that area of 
the Package is needed.  
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6.2.3 Worksheets 

A Worksheet can be considered as a page of the Workbook. To realise the benefits of this 
relationship, all Worksheets should be tightly related to the name of the Workbook.  

For example, a Workbook called Fuel could have Worksheets related to fuel injector setup, fuel 
pump control, fuel used calibration, fuel transient setup, fuel tuning, fuel pressure control, Etc. In 
an ignition Workbook, appropriate Worksheets could relate to dwell, ignition timing, ignition 
compensations, ignition cut, individual cylinder ignition compensations, Etc.  

Example of Workbooks and Worksheets laid out in a structured fashion 

 

6.2.4 Default Package Layout 

A default layout is specifically designed to make using the Package as easy as possible.  

When a Package is created, the developer of the Package has the option to create a default 
layout. Once the layout is created, the whole Package can be saved so that this default layout is 
immediately available in M1 Tune.  
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Default layouts are distinguished from user created and customised layouts by the green 
Worksheet tabs and window surround.  

Example of default layouts 

 

These default Worksheets are fixed in their layout and location and cannot be modified by the 
end user.  

In M1 Tune, the user can use the default layout provided with the Package or configure their own 
layouts.  
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7 OPENING OFFLINE PACKAGES 

The Open Package window provides information and access to package details, filtering and 
history. Packages saved on the PC can be opened as follows:  

1. Select File »Open Package , or select Browse Pages from the Quick Launch fly-out.  

► The Open Package window displays.  

Example Open Package window 

 

2. Identify and select the required Package using the Package details, filtering and history 
information available from this window.  

3. Select the Open button.  

►The selected Package opens.  
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7.1 ABOUT PACKAGE DETAILS 

The Open Package window displays a list of offline Packages. The details about each of the 
offline Packages is shown, these are defined in the following table. Also see, ABOUT THE 
PACKAGE FILTERING OPTIONS and ABOUT THE PACKAGE HISTORY. 
 

Details  Definition  

State  Icons indicating ...  

Vehicle ID  
A unique identifier of the vehicle in which the package is used. The vehicle ID 
is a useful way to find Package(s) for a particular vehicle.  

Serial #  

The serial number field records the ECU number with which the package is 
associated. Whenever a package is sent to an ECU, M1 Tune will attempt to 
send it to the matching ECU. If the package is to go into a different ECU, then 
the serial number must be changed to the serial number of the receiving 
ECU.  

Comment  
Comments are used to keep track of changes to the Package over time. This 
is the recommended method to use for recording the sequence of changes 
made to a Package. This field assists in selecting the correct Package.  

Firmware  The firmware property is the name of the firmware group.  

Firmware 
Version Name  

Used to describe the specific version of the firmware.  

Firmware 
Version  

An incrementing number that uniquely represents each unique build of the 
package.  

Hardware  
This field identifies for which M1 ECU model the package was built. Each M1 
Package is built to work with a particular M1 model. A package built for an 
M170 will have a different pin allocation to a package for an M190.  

Modified 
Date/Time  

This field records the last time that this particular package was modified.  

Imported 
Date/Time  

This field records the date and time that the package was imported onto the 
PC.  

 

7.2 ABOUT THE PACKAGE FILTERING OPTIONS 

The filtering options provided down the left hand side of the Open Package window can be very 
useful in helping to find specific Packages.  

Note: When working on a Package, update the Vehicle ID and the Description as you go 
so that the most benefit can be realised when the filtering feature is later used. 
This is important to make it easy to find and sort Package versions.  

The result of using each of the filtering options is defined in the following table.  
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Filter option  Result  

All  Shows all packages on the PC (no filtering)  

Recently imported  
Lists all packages grouped by imported date, sorted by the most 
recently imported into Tune  

Recently Modified  
Lists all packages grouped by Modified date, sorted by the most 
recently modified from within Tune  

By Firmware  
Shows all packages grouped by firmware name, then sorted 
alphabetically  

By Hardware  
Shows all packages, grouped by the M1 hardware model, then sorted 
alphabetically  

By ECU  
Shows all packages grouped by ECU type and ECU number, then sorted 
alphabetically  

By Vehicle Id  
Shows all packages grouped by the Package vehicle ID, then sorted 
alphabetically  
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7.3 ABOUT THE PACKAGE HISTORY 

The Open Package window shows the history of each Package. This history is displayed using a 
graphical State tree.  

This State tree uses coloured boxes to denote the state of a Package, and connecting lines to 
indicate the lineage of the Package.  

Using these lines it is possible to determine from where a particular version of a Package 
originated.  

Displayed along the bottom of the Open Package window are the seven possible states.  

 

The Package states as indicated by the coloured keys are defined as follows.  
 

State  Definition  
Example State 
Tree  

Light Orange - 
Unknown  

M1 Tune cannot determine the source of this Package.  

 

Cyan - Auto 
Saved  

A modified Package that was never saved by the user, 
M1 Tune auto saves Packages every minute.  

Blue - Tuned  
A Package that has been changed offline but not sent 
to an ECU.  

Green - Matched 
ECU  

A Package that matches exactly to a tune that has been 
seen in an ECU.  

Dark Orange - 
Migrated  

A Package that has been changed based on another 
Package.  

Purple - Merged  

This scenario occurs when there are multiple people 
working on a single ECU. If two people are working in 
different parts of the Package, but sending to the same 
ECU, it means that changes have been applied "on top 
of" (or merged) into a package that was different to the 
original package (since one user updates the ECU 
sometime between the other user opening the Package 
and sending changes).  

Red - Partial 
Merge  

In some cases a full merge cannot fully succeed since 
two users changed the same part of the package 
(causing a conflict that cannot be automatically 
resolved); but some of the data was merged.  
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8 COPYING, MOVING AND DELETING PACKAGES 

Moving M1 Package files via Windows Explorer is not recommended.  

MoTeC M1 Packages are not intended to be copied, added, deleted or moved by use of the 
standard Windows file system. It is recommended that when moving Package files the Import, 
Export and Export Mail functions are used, these are available from the Open Package window, 
see OPENING OFFLINE PACKAGES. 

Use the Import and Export functions when a package needs to be moved from one PC to 
another.  

8.1 ARCHIVE FILES 

MoTeC has implemented a new method of adding and moving files within the M1 system. The 
new file type is called an M1 Archive file. Its purpose is to remove the need for users to manually 
find their way around the file system when moving or adding files.  

The M1 Archive may contain multiple files and complete directory structures, it is similar to a 
self extracting ZIP file. The locations are automatically determined when the file is extracted, 
requiring no input from the user.  

The archives used within M1 Tune are described in this table.  
 

Archive file 
extension  

Purpose  

.m1pkg-archive  Files required to add a new package to M1  

.m1prj-archive  All files required for an entire M1 project  

.m1lic-archive  M1 licence file  

.m1wsp-archive  Files required to install a new workspace configuration in M1 Tune  
 

8.2 EXPORTING PACKAGES 

To export packages:  

1. Open the Open Package window from the Quick Launch fly out, or the menu option File 
»Open Package.  

2. Using filters and searches as necessary, find and select the Package to copy.  

3. Select the Export File button to export the archive to a USB stick or drive, or the Export Mail 
button to attach the archive to an email.  

►The file created has an extension of .m1pkg-archive. The filename is a combination of the 
Firmware, Hardware, Vehicle ID fields.  

4. Distribute the Package archive file as required.  
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8.3 IMPORTING PACKAGES 

Once a Package archive is received, there are two options for installing (importing) the package; 
using the Import function as described below, or by double-clicking on the archive filename.  

Both methods result in the package being unpacked and files added to the correct locations so 
that the Package becomes available in the Open Package window.  

1. Open the Open Package window from the Quick Launch fly out, or by selecting menu 
option File »Open Package.  

2. Select the Import File button.  

3. Browse to the location of the archive file, select it and click Open.  

8.4 DELETING PACKAGES 

To delete Packages:  

1. Open the Open Package window from the Quick Launch fly out, or by selecting menu 
option File »Open Package.  

2. Select the Package to delete (Multiple Packages may also be selected) and right click on the 
selection.  

►The right-click menu displays.  

3. From the right-click menu, select Delete.  
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9 CREATING WORKBOOKS 

To create Workbooks:  

1. Select menu option Layout »New Workbook.  

►A prompt to enter a Workbook name displays.  

2. Name the new Workbook.  

►A new empty Workbook is created.  

3. Add Worksheets and components as required.  
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10 WORKSHEET COMPONENTS 

A new Worksheet is created blank. The user can then populate the Worksheet with a variety of 
components that can be placed anywhere on the Worksheet to create a customised layout that 
suits the application. The components themselves can be moved, resized, and customised so 
that they are appropriate to the worksheet.  

Every component has a unique set of properties specific to that component type. These 
properties determine how the component looks and behaves. The property values are set within 
M1 Tune for tuning of the M1 ECU.  

Note: The same component type can be used on multiple Worksheets. However, the 
property values are specific to that one component instance; they are not shared 
with other instances of that component type in other places.  

 

The component types that are available include:  

• Calibrate  

• Table Target  

• Channel List  

• Time Graph  

• Scatter Plot  

• Histogram  

• Colour Graph  

• Notes  

• Gauges  

Examples of gauge type components. 
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10.1 ACCESSING COMPONENT PROPERTIES 

To access the properties of individual components:  

1. Highlight the component, and press F5, or right-click on a component and select 
Properties... from the menu list.  

►The relevant properties window displays.  

Example of the properties window for a Time Graph component 
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10.2 CALIBRATE COMPONENT 

For those intending to make changes to their Package, the calibrate component is the most 
important component in M1 Tune, it is an all in one place to view and modify tables and 
parameters. If you want to see the value of any item in M1 Tune, it can be found in the Calibrate 
component.  

Calibrate also allows quick functions for lambda tuning and sensor calibration readings.  

It consists of two main parts:  

• The Calibrate list, which displays the value of channels. See Calibrate List  

• Calibrate table and/or graph. When tuning a vehicle, the calibrate table and graph are 
generally the most important components used. To make the best use of the available 
screen space, the graph and table can be cycled between three views:  

− Table and graph  

− Table only  

− Graph only  

See Changing Calibrate Display Options. 

It is also possible to zoom in so that the Calibrate component uses the whole screen area.  

See Calibrate Component Properties or information on configuring what is displayed in the 
Calibrate component.  

Example Calibrate window 
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10.2.1 Calibrate List 

The Calibrate list contains channels and their values and is displayed on the left-hand side of the 
Calibrate component.  

Note: What channels are displayed in this list is governed by the list type selected in the 
Calibrate properties. See Calibrate Component Properties. 

How the list displays information can be adjusted using the Calibrate list toolbar (located at the 
top of the list) as defined below.  

Calibrate List Toolbar 

 

Each option in the toolbar operates as described below.  
 

 

Select in what manner the list is displayed - a flat list, compact tree or 
full tree. The full tree mode is very useful as it reduces the visible list 
to a more manageable size by grouping the contents, this grouping 
relationship is as the items were organised by the application 
developer in M1 Build.  

 

Toggles the channel values on and off. When on, the list includes the 
current live values of any channel that match the current Calibrate list 
type.  

 

Limits the list to show only items that are currently invalid. Invalid 
items are tables or channels that contain values that do not meet 
their validation criteria. These items should normally be corrected 
before running an engine.  

 

When you are in comparison mode (comparing one Package with 
another), the Calibrate List indicates what is the same and what is 
different between the two Packages, and by how much. Selecting 
this option limits the list to only show items that are different. 

 

Search input area that will search through the current list for any 
items that match both the current Calibrate list type, and the search 
value.  
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10.2.2 Calibrate Component Properties 

The Calibrate (component) Properties is used to configure the contents of the Calibrate 
component.  

The Item Selection in the Calibrate Properties window functions as follows.  
 

Item Selection - All Items  Show all items (everything in the entire M1 Package)  

Item Selection - Matching 
Items  

Limits the items in the Calibrate list by matching a specified 
keyword. For example, limiting items displayed by the keyword 
"Fuel" focuses the list on the application and makes the 
component easier to use.  

Item Selection - User defined 
Items  

Limits the items in the Calibrate list by displaying only user 
defined items in the list.  

 

The colours, ranges and other display settings can also be configured.  
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Example Calibrate Properties window 

 

10.2.3 Changing Calibrate Display Options 

To cycle between views and to zoom.  

1. Select the Calibrate component.  

2. Press G to cycle through the three views.  

3. To zoom into the current view press F6.  

►The Calibrate component occupies the whole screen.  

4. To leave zoom mode press F6 again, or move to another Worksheet.  
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Example Table and Graph 

 

Example Table Only 

 

Example Graph Only 
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10.2.4 About Calibrate Tables 

The calibrate table is the most important part of the M1 Tune application.  

There are three fundamental aspects of tables:  

• Table axes  

• Table interpolation  

• Table values - entering, importing and exporting.  

10.2.5 Table Axis 

Each table in the Calibrate component can have up to three axes. These Axis channels are 
pre-configured when the Package is built and cannot be changed.  

It is possible to:  

• Add, remove and adjust sites and values  

• Turn on any, all or none of the axes  

• Swap axes  

• Reverse the sort order.  
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10.2.5.1 Table Axis Display Options 

To adjust how axes are displayed.  

1. Right click on the table and from the right click menu select Axis.  

►The axis options display.  

 

2. Select the relevant option.  
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10.2.5.2 Table Axis Setup 

To adjust axis sites and values.  

1. Highlight the table and press A, or right click on the table and select Axis »Setup Axis.  

►The Axis Setup window displays.  

Example Axis Setup window 

 

10.3 Table Interpolation 

The M1 Tune Calibrate component has enhanced interpolation functionality to make building 
and smoothing tables easier.  

Note: Sites marked as tuned are not modified by the interpolate function. See Marking 
Sites as Tuned. 

 

Interpolate 
(bi-linear)  

Takes the corner values from the selected area and interpolates across then 
down from there. This is followed by a horizontal interpolate across each row in 
the block.  

Interpolate 
Vertically  

Takes the top and bottom values and evenly distributes the values in the 
middle.  

Interpolate 
Horizontally 

Takes the left and right values and evenly distributes the values in the middle. 

Smooth  

When a single row is selected, the smooth function performs the smooth from 
the values left and right of each point. A block smooth will take each value in 
the block and perform a weighted smooth from each surrounding sites. More 
weight is given to the vertical and horizontal values, less to the corners.  

 

See Applying Interpolation. 
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10.3.1 Applying Interpolation 

To apply interpolation:  

1. Select the required area (sites).  

2. Right-click on the selection.  

►The Right Click menu displays.  

3. Select Adjust »[required option]  
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10.4 Marking Sites as Tuned 

It is possible to mark a site or range as 'Tuned'. As the value is considered tuned, any interpolate 
function will not modify these values.  

1. Select the table values.  

2. Press Backspace.  

►The sites are marked with a red square and the values are considered to be tuned.  

 

See Unmarking Sites as Tuned. 

10.5 Unmarking Sites as Tuned 

To unmark sites as tuned:  

1. Select the site(s).  

2. Press Delete.  

►The sites are unmarked and the red square is removed. The value(s) are considered to be 
untuned.  
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10.6 Entering Table Values 

When a table is selected, there are a few options on how to enter values.  
 

Direct entry  

1. Select the site.  

2. Type in the number and press Enter.  

Press Escape to cancel the entry.  

Increment / Decrement 
the table value  

1. Select the site or region.  

2. Press Page Up to increase the values in the selection in medium 
steps, or Press Page Down to decrease the values.  

Increment / Decrement 
the table value fast  

As for Increment / Decrement the table value. However, use CTRL 
Page Up to change values in larger steps.  

Increment / Decrement 
the table value Slow  

As for Increment / Decrement the table value. However, use CTRL 
Page Up to change values in smaller steps.  

Scale or Offset  

1. Select the site or region.  

2. Press = to display a maths expression window.  

3. Enter an expression to perform on the selection. For example:  
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10.7 Importing and Exporting Tables 

When using the M1 Tune application, there can be a large number of items to fill in a table. To 
make this task faster, and more accurate, it is possible to export and import values into M1 
tables; there are a number of methods available.  

Each method is selectable from the Component menu or from the Right Click menu.  
 

Export »Entire Table »To File...  
 

OR  
 

Import »Entire Table »From File...  

Export or import the complete table, its axes and 
axis values. These tables are in a format that 
cannot be edited outside of the M1.  

Note: This is the only way to copy a 3 axis 
table in one step, and is the 
preferred method for copying a 
table from one Package to another.  

Export »Current View »To CSV File...  

 
OR  
 

Export »Current View »To Clipboard  

Exports only the current 2 viewable layers (axes) 
of a 3 axis table, or the entire table for 2 and 1 axis 
tables. This data can be exported to clipboard for 
a fast copy, or to a CSV file if it is to be sent or 
edited outside of M1 Tune.  

Import »Current View »From CSV File...  

 
OR  
 

Import »Current View »From Clipboard  

Imports table layers (axes) exported using the 
export current view function.  

 
See Copying and Pasting Table Data. 

10.7.1 Copying and Pasting Table Data 

When using the M1 Tune application, there may be a need to copy and paste part of a table's 
data. These functions are Copy Data and Paste Data.  

Note: This is the only method available for copying and pasting selections of table data. 
The Cut, Copy and Paste functions will not operate for table data, they are 
designed to only act at the component level. For example: even if part of a table is 
selected and Copy chosen, then the whole Calibrate component is copied.  

Each function is selectable from the Component menu or from the Right Click menu.  
 

Copy Data  
Copies only the selected table values, it does not copy the axes or any 
other table information.  

Paste Data  Pastes the data copied using the Copy Data function.  
 

 
See Importing and Exporting Tables. 
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10.8 TABLE TARGET COMPONENT 

The Table Target component is commonly used when tuning an engine. The whole component 
box represents the currently selected table. The floating red square shows where the live 
channel values sit, compared to the currently selected table site.  

Example Table Target 

 

The most common use of the Table Target is when tuning an engine on the dyno. The tuner 
would select the site that they would like to tune. The engine would then be adjusted in throttle 
or load so as to position the square in the middle of the Table Target component box. When the 
square is in the middle of the target, the engine live value is the same as the selected site value.  

Once the engine live value and the site match, any changes made to that site value will 
correspondingly by made to the running engine live value.  

10.9 CHANNEL LIST COMPONENT 

The Channel List component displays a filtered and sorted list of channels, and their live values.  

Example Channel List 
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The list can be filtered via the Channels Properties window and the Search bar. If not visible, the 
Search bar can be set to display on the Display tab of the Channels Properties window.  

The Channels Properties window controls the following:  

• Which channels to display  

• The caption of the component  

• Whether the context help is displayed, and if so, to the left or right of the component  

• Whether the Search Toolbar is shown or hidden.  

Note: Channel lists display the live values, so the values themselves cannot be modified.  

10.10 TIME GRAPH COMPONENT 

A Time Graph component tracks and displays the live values for the selected channels.  

Example Time Graph 

 

The graph uses time as the X axis, and the individual channel range for each channel group on 
the Y axis.  

It is possible to pause and restart the time graph (T), see LIVE DATA CONTROL for more details.  

The Time Graph Properties window controls the following:  

• The caption of the component  

• Add and remove channel groups and channels to display  

• The order of channel groups and channels  

• The layout of channels  
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• Various display options such as axis information, ranges and units  

• The period of time shown in the graph and other telemetry options  

10.11 SCATTER PLOT COMPONENT 

The Scatter Plot component is a live updated component that is used to show a trend of two 
related channels on a plot.  

A common use of this sort of chart is to plot the relationship between the boost channel and 
RPM, or to show how the oil pressure changes with oil temperature.  

Example Scatter Plot 

 

The Scatter Plot samples the two selected channels at 50 Hz, and plots the intersection between 
the two channel values on the chart. Each plotted value will stay displayed on the screen for a 
configurable length of time.  

The Scatter Plot Properties window controls the following:  

• Channel selection and settings  

• Various display options  

• The period of time the plot is displayed (via the Telemetry tab).  
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10.12 HISTOGRAM COMPONENT 

The Histogram component provides a graphical representation of the proportion of time that a 
channel has been within a specific value range. For example, the amount of time that an engine 
has spent in high boost.  

A common histogram shows the amount of time that an engine has spent at particular RPM 
ranges, as shown in this example histogram.  

Example Histogram 

 

The Histogram Properties window controls the following:  

• Channel selection and settings  

• Various display options  

• The period of time (via the Telemetry tab).  

  



 

 User Manual

WORKSHEET COMPONENTS

 

Printed documents are not controlled Page 42 

10.13 COLOUR GRAPH COMPONENT 

The Colour Graph a component shows a coloured representation of a channel over time.  

The example below shows and engine temperature colour graph over time, where the engine 
starts up cold, warms up, cools down and so on.  

Example Colour Graph 

 

This type of graph is useful, such as when comparing multiple exhaust temperatures. If all 
cylinders are displayed on this graph at once, a visual representation is given showing how each 
cylinder is climbing in temperature compared with the other cylinders.  

The Colour Graph Properties window controls the following:  

• Channel selection and settings  

• Various display options  

• The speed of the time line (via the Telemetry tab).  

10.14 NOTES COMPONENT 

The Notes component is a method that allows either the application developer or the end user to 
leave informational notes about the Worksheet.  

Note: As the same Notes component may be used for multiple Packages, it is important 
that the Notes component is specific to the Worksheet, not the Package.  

When an application developer is creating standardised Worksheets for a Package, this 
component can be used to provide specific Worksheet information to the end user. As the 
standardised Worksheets are configured on a per Package basis, the Notes can be tailored to the 
individual application.  
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The use of Notes by the end user is also beneficial when creating their own customised 
Worksheets. The main use of the Notes component is to explain how best to use the Worksheet, 
and the purpose of each component.  

Example Notes 

 

10.15 GAUGES COMPONENT 

The Gauges component is provided to display channels in a fast and easy to read manner.  

This is extremely important when an engine is on and running. A gauge is often the quickest way 
to keep an eye on vital engine condition channels.  

For example, with one glance it is possible to see engine speed, Inlet air temperature and engine 
oil pressure.  

Gauge types include the following.  
 

Numeric  Bar  Dial  Status Light  

A single channel 
numeric display of a 
channel value  

A vertical or 
horizontal colored 
bar graph  

A dial type of gauge  
Warning light or status 
light for a particular 
channel or condition  
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11 USING M1 TUNE 

To make effective use of this application, an understanding about the following elements is 
essential.  

• Using Worksheets  

• Configuring channels  

• Using live data recording  

• Dyno tuning with M1Tune  

• Using the "Q" Quick lambda function  

• Using the "W" and "L" fuel tuning functions  

• Using the "Q" calibrate functions  

• Making live data changes to the ECU  

• Saving live changes to the ECU  

• Viewing live pin values  

11.1 WHAT TYPE OF WORKSHEET TO USE 

The following table provides information about Worksheets and how they should be used.  
 

Supplied 
Worksheets  

When new to M1 Tune, it is worth using the supplied Worksheets. They 
are configured to show all the main parts of the application, and ensure 
all required components and channels are configured.  

These Worksheets also show examples of how you can setup your own. 

Custom 
Worksheets  

Worksheets can be 
customised any 
way that the user 
requires, but 
experience has 
shown that they are 
generally 
configured as a 
generic or task 
specific  

Generic  

A generic Worksheet can contain a single calibrate 
component. The calibrate list would be set to All, and the 
search bar displayed. A combination of standard 
diagnostics gauges such as engine temperature, oil 
pressure Etc. should also be added.  

The Search toolbar would be used to find required items 
(channels). For example, search on "Fuel" will list all like 
items.  

Task 
specific  

M1 Tune is easiest to use if dedicated Worksheets are 
created to suit particular tasks. This ensures that when main 
fuel numbers are to be updated, there is a Worksheet 
available that is specifically setup for fuel tuning.  

Configuring Worksheets to suit fuel tuning, ignition timing, 
compensations, injectors, lambda, and Ref/Sync would 
make ECU configuration more efficient.  
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11.2 USING SUPPLIED WORKSHEETS 

Using the supplied Worksheets is the easiest way to use M1 Tune for 
specific tasks. MoTeC have made available sample Worksheets with 
each Package that make performing these tasks easier. These 
Worksheets are contained within the Workspace provided with the 
Package. The Workspace contains three Workbooks, they are Tuning, 
Setup and Initial Configuration.  

11.2.1 Initial Configuration Workbook 

Example Worksheets in the Initial Configuration Workbook 

 

The Initial Configuration Workbook is designed to include Worksheets that are normally be filled 
in before the ECU is plugged in, or before the engine is started. Among others, this workbook 
allows the configuration of the Transmission, Cylinder TDC's, Fuel Injectors and CAN 
information.  

Unique to the Configuration Workbook is the Test Modes Worksheet. This sheet contains the 
settings to allow the testing of auxiliary outputs, run an Ignition timing test, and to complete the 
DBW step test.  

11.2.2 Setup Workbook 

Example Worksheets in the Setup Workbook 

 

The Setup Workbook contains Worksheets that can be used either offline or online, but they 
should be filled in before starting the engine. After starting the engine, some of these settings 
may need modifying.  

11.2.3 Tune Workbook 

Example Worksheets in the Tune Workbook 

 

The Tune Workbook includes sheets that are generally used when tuning the running engine. 
From ignition and fuel main tables, to trims, starting, transients and closed loop.  

Note: These Worksheets are just a starting point for how to configure the ECU. There 
may be extra or specialised sheets that can be added as required.  
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11.3 MANAGING DATA (CHANNEL) PROPERTIES 

Within M1 Tune, the user has the option to configure any channel to suit their local 
requirements.  

The Data Properties window shows all channels in use by the current Package, and their 
property settings.  

Note: These channel properties are global, and any change that is made will reflect 
across the entire application.  

Example Data Properties window  

 

11.3.1 Accessing Data Properties 

1. Select menu Tools »Show Data Properties...  

►The Data Properties window displays. To change the properties of any of the channels, 
including channel colour, units, decimal places, min/max scaling and warning limits.  

See Editing Channel Properties. 
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11.3.2 Editing Channel Properties 

The channel properties are set in the Channel Properties window. There are two methods of 
accessing this window.  

Note: These channel properties are global, and any change that is made will reflect 
across the entire application.  

1. From the Data Properties window, see Accessing Data Properties, select Edit.  

►The Channel Properties window displays.  

2. Set the channel properties as required. See Setting Channel Display Limits. 

Or 

1. From the Channels component, right-click on the required channel and select Properties  

►The Channels Properties window displays.  

2. Select the Edit button.  

►The Channel Properties window displays.  

3. Set the channel properties as required. See Setting Channel Display Limits.  

  



 

 User Manual

USING M1 TUNE

 

Printed documents are not controlled Page 48 

11.3.3 Setting Channel Display Limits 

In addition to other settings, the Channel Properties window also controls channel limits. 
Warning limits created for a channel are consistent across the whole application.  

Note: These channel display limits are in addition to the high and low parameter limits 
displayed in the Error Status list, see ERROR MANAGEMENT AND STATUS LIST. 

Oil pressure example 

If an oil pressure sensor is setup with a low limit of 100kPa, as shown here...  

 
...then in any location within M1 Tune where the oil pressure is shown, the value displays in red rather 
than in the default color. This is shown below in the oil pressure Bar Graph (for Bar Graphs the bar itself is 
red rather than the number) and in the Channel List.  
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11.4 LIVE DATA CHANGES 

When modifying the M1 ECU within M1 Tune, any changes made are "Live", meaning the change 
happens in real time the moment the new value is entered. That is, when an engine is on a site, 
and the value of that site is changed, the ECU will immediately start using the new value.  

Note: Even though the ECU may be operating on new values does not mean they are 
saved, see SAVING CHANGES TO ECU DATA. 

In some instances, a live change is not possible. This occurs where a parameter value has 
underlying dependencies, requiring simultaneous update of all relevant parameters. In these 
circumstances the change will require an ECU reset to take effect.  

Parameters that require an ECU reset if changed can be identified by the red flag  after their 
name.  

11.5 SAVING CHANGES TO ECU DATA 

Although live changes in M1 Tune have an immediate effect on the ECU, this change is not 
saved into flash memory at this point, but is stored in RAM. The ECU will still have the original 
value stored in its flash memory. If the connection between M1 Tune and the ECU is lost, the 
ECU will revert back to its stored values.  

For any changes in M1 Tune to become permanent, it is necessary to save the Package. When a 
save is performed, the changes are saved to the Package file on the PC, and also saved into the 
ECU flash memory.  

To save, select menu option File > Save.  

Example saving scenario 

1. A user is tuning an engine, and at 100% throttle and 5000 RPM there is a fuel number in the ECU of 49.5. 
The ECU is using this number whenever the engine is at 5000 RPM and 100% throttle.  

2. The user selects this site and changes the value from 49.5 to 55.5. Tune is still connected to the ECU, so 
when the engine goes to 5000rpm and 100% throttle, the ECU will use 55.5 for the fuelling.  

3. If the user then disconnects M1 Tune from the ECU without saving, and the engine goes back to 
5000RPM and 100% throttle, the ECU will revert to using 49.5 as the fuel number.  

4. If the user plugs M1 Tune back in, the user will be offered to reapply the previous set of changes, in this 
case the 55.5. This value is still not saved in the ECU at this point.  

5. Finally, the user saves the Package, and the 55.5 is saved into the ECU flash memory and saved into the 
Package on disk.  

6. When the user now disconnects M1 Tune, the ECU will use 55.5 as the fuel number for 5000 rpm and 
100% throttle.  
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11.6 LIVE DATA CONTROL 

M1 Tune is able to display live data as it happens.  

The values are displayed in a combination of charts, graphs, and gauges. Displaying live data 
allows monitoring of the running engine.  

At times, it may be necessary to go back in time to look at an event that occurred during the live 
data display. To do this, it is necessary to use the Time Graph component.  

To view a past event it is necessary to pause the live display using the Pause button on the menu 

toolbar  or by pressing T (recording of live data continues to occur, but the screen is not 
updated). When M1 Tune live data is paused, the "Connected" icon flashes between 

 and  and channel values pause in all components.  

After pausing, it possible to move the cursor in the Time Graph back to the point in time that is to 
be examined (all components display values as they were for the time selected). From this 
position, you can zoom in and out to look at data in more detail, same as in i2.  

Using the Pause function is a fast way to work during an engine tune. The engine can be ramped 
up through its range, and once that is done, the M1 Tune live data can be paused. This allows 
the tuner to now go back and examine in detail the ramp run, and all values from that point in 
time.  

When the M1 Tune application is to taken out of pause (by using the Pause button or pressing T), 
the component value displays and the Time Graph will return to the live display state.  
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11.7 Q CALIBRATE FUNCTIONS 

The Q key performs special functions on parameters and tables that were not available in older 
ECUs. The function is different depending on the selected item.  

Note: The Q function can now perform a calibrate against any parameter or table 
displaying the Q icon.  

For example   

When the item is selected, and the Q key pressed, M1 Tune performs a special function that will 
generally calibrate that value.  

An example of this is setting throttle position high and low values. The process for this would be 
as follows:  

1. Select the Throttle Pedal Main Closed parameter. 

 

2. Close the throttle and press the Q key.  

►The current pin voltage is determined and Throttle Pedal Main Closed parameter is set to 
that value.  
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11.7.1 Quick Lambda Function 

When Q is used on the Fuel Main table, the function performed is a Quick Lambda.  

A Quick Lambda function, when used live (that is, live data is not paused), takes the single site 
closest to the current running engine location, and place that site's details in the Quick Lambda 
window, for example:  

 

M1 Tune will then retrieve the Fuel Aim value for this site, and the current Lambda value.  

To perform the Quick Lambda on this site, review the information and click OK.  

This same Quick Lambda function also works with recorded data. See Dyno Tuning with M1 
Tune. 

11.7.2 Dyno Tuning with M1 Tune 

To make engine tuning faster, it is possible to Quick Lambda fuel table values at a point in the 
past using pause live data, see LIVE DATA CONTROL.  

The process is as follows:  

1. Connect the laptop to the M1 ECU and watch the live data in M1 Tune.  

2. Ramp engine through the Ramp test.  

3. Press the T key to pause the live data display.  

4. Scroll back through the saved data on the Time Graph and review the ramp test.  
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5. When a site (data) is found that needs to be re-tuned with quick lambda, press the Q key.  

►M1 Tune displays a summary window of the action about to be performed. For example:  

 

6. Select OK to run the Quick Lambda function.  

7. Press T to restart display of live data.  

11.8 W AND L FUEL TUNING 

When performing fuel tuning, the Q function adjusts the closest site to the current values. There 
is another option that performs a similar function, " W ".  

When " W " is used while connected live on an engine, M1 Tune:  

1. Selects the site closest to the current engine running site.  

2. Performs a quick lambda against this site using the current lambda reading and the lambda 
aim value for that site.  

3. Tune then performs the same quick lambda function against the next site in the table in the 
direction of more engine speed and more efficiency (plus the diagonal site) using the current 
lambda reading, and aim values for those sites.  

This same function works using recorded data.  
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11.9 LAMBDA WAS 

If the fuel table needs to be tuned from data either offline or offsite, the " L" ( Lambda Was) 
function can be used.  

This function works exactly the same as " Q " does but with user entered lambda values. When " 
L " is pressed, a window prompts for the user to enter the recorded lambda value, rather than 
using a recorded value.  

11.10 VIEWING LIVE PIN VOLTAGE VALUES 

At times it is necessary to know the actual voltage that is on a particular pin, whether that is an 
input or an output.  

Note: If connected to an ECU, all voltage values shown are instantaneously updated in 
real time.  

1. Select menu Online »Monitor Inputs / Outputs.  

►The Monitor Input/Output window displays showing the Digital Input tab, for example:  

 

2. Select the Analogue Inputs tab to display all analogue pin voltages, for example:  
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11.11 VIEWING THE ECU PIN CONFIGURATION 

ECU pin configuration in M1 is determined when the package is built and changes with each 
Package, no longer is it one solution fits all. Therefore, rather than provide a wiring diagram for 
each Package and for all M1's, M1 Tune generates a Wiring Summary,  

The M1 Wring Summary shows the pin number used for each input and output, along with its 
type, name and abbreviation.  

Unused inputs are shown without any information in the Usage column.  

To display and/or print the Wiring Summary:  

1. Select menu Help »Package Wiring...  

►The Wiring Summary window displays, for example:  

 

2. To print the Wiring Summary, use the Print button  at the top left of 
the window.  
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11.12 ERROR MANAGEMENT AND STATUS LIST 

Note: Sensors not in use should be set to disabled where possible so that the Error 
Status list, which is displayed in the Status window, is only used for genuine 
errors.  

M1 Tune senses that a channel has gone into error when its value goes outside the configurable 
channel parameter limits.  

The channel parameter limits are configured within the sensor settings, using the fault low and 
high limits.  

Note: It is also important to set a reasonable default value for the sensor parameter. If 
the channel goes into fault, the sensor will report its value to be this default value. 
Consider how this value will affect the running engine in the event of a channel 
fault.  

How these errors are displayed is shown below.  

 

When an error occurs, the channel parameter and its value are added to an Error Status list and 
the following popup displays to notify the user of the change to the list of errors.  

 

The popup lists the current number of errors, but only appears if there has been a change to the 
number of errors.  
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Press F3 to display the Status window.  

Example Status window 

 

The Status window displays all current Errors and Status values. To see only errors, de-select 
the Show Messages checkbox box from the bottom of the window.  

Sometimes, the error will only be active for a short period of time, and it may not appear in the 
Status list when it is opened at a later time. In this instance, select the Event Log tab to see a 
history of errors, when they occurred and for how many times.  

Example Event Log 
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11.13 INPUT VALIDATION AND INVALID ITEMS 

When a Package is created, parameters and tables are normally set up with input validation.  

Input validation sets high and low limits for the parameter. When a Package is first built, most 
values are set to 0. In many instances this will not be valid value, and the table or parameter will 
display as containing invalid items.  

Invalid items are displayed with a yellow triangle (as shown below). In this example, the valid 
peak timer values are 0.3ms to 8.4ms, and the current parameter value is 0.0ms.  

 

It is possible to search for all invalid parameters using the Invalid Configuration Data Summary 
window, which is displayed by pressing F7. Within this window, it is possible to update the 
parameters and channels to valid values.  

Example of a the Invalid Configuration Data Summary 
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11.14 MIGRATING DATA 

Data migration refers to the copying of tune data from one Package to another.  

Migration can be required for a number of reasons. The most common is to populate new 
firmware. New firmware will initially have empty fuel maps, ignition maps, sensor calibrations 
Etc. Rather than requiring the user to manually search through the Package and fill in all of the 
tables and parameters, existing M1 Tune data can be migrated to the new Package using the 
migration tools.  

There are two main method by which migration can occur.  

• Auto migration  

M1 Tune automatically takes values from the source and migrates them into the destination. 
This will occur when you install new firmware into an ECU and the previous firmware 
matches the new firmware.  

• Manual migration  

The user uses compare mode features to explicitly copy values from the source to the 
destination Package. Manual migration is completed by opening two M1 Tune files at the 
same time, and using the compare or migrate tools to copy the data.  

11.14.1 Auto Migration 

Auto Migration copies:  

• Tables  

• Parameters  

• User Package Details  

• Log setups  

• Package Workspaces  

Items will not migrate if:  

• The source does not exist  

• The destination does not exist  

• Item quantities have changed (for example, item changes from Pressure to Force)  

• Item changes data type (for example, item changes from a floating point to an enumeration)  

• An enumeration name does not exist  

• The user performing the migration does not have appropriate security permissions  



 

 User Manual

USING M1 TUNE

 

Printed documents are not controlled Page 61 

11.14.1.1 Manual Migration 

As M1 projects can become quite complex, it may be required to compare two packages to see 
what has changed.  

To do this:  

1. Open an offline Package, or connect online to an ECU.  

2. Select menu File > Add Compare Package.  

When in the compare mode, the user can view the Packages through the usual components, 
such as Calibrate, and see the differences in the data.  

There are also some dedicated windows to assist in looking at the changes. Two of these are 
accessed from Tools > Compare Data or Tools > Compare Firmware. The windows displayed 
from these options display the differences with a red highlight. The data in these windows can 
be both viewed and modified.  
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12 LOGGING 

Logging in the M1 system includes a number of advanced features that make it highly 
configurable. It is possible to set it up logging from a simple one user environment to the 
requirements of a highly regulated category. There are 8 independent logging systems to cater 
for a variety of requirements.  

M1 logging can be configured so that it is user/role specific, so the tuner may be able to see one 
set of data, scrutineers a different set and the chassis engineers another. The data that each user 
can see may be overlapping or separated.  

Setup can be individually secured so that each user can easily configure and see what they have 
access to, and no more. Using these features, a strictly separated category logging system can 
be setup.  

For a simpler option, logging can be configured to have a single log setup, which uses all 
available memory, and has no security. This is a similar configuration to the M800 logging setup 
where logging is open.  

Example Edit Logging window  
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12.1 LOGGING FEATURES 

The M1 logging system has the following features:  

• Eight independent log systems  

• Tightly integrated with user security to ensure that users can only download and convert 
logging that they have access to view  

• Ability to download logging, but not to convert logged data  

• Control on user access to view restricted log setups  

• Reserved memory allocation per log set  

• Cyclic logging  

• Configurable start / stop logging parameters  

• Selectable logging rates  

12.2 LOGGING CONFIGURATION 

To configure M1 logging, select which log data set is intended to be used for logging.  

From the Channels list, drag and drop channels or groups of channels into the logging update 
rate branch to suit the required log rates.  
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13 SECURITY 

The MoTeC M1 system provides an advanced security system based on public-private key 
cryptography. This security method means that once an ECU has been correctly configured with 
appropriate security settings, it is practically impossible to access the ECU without the correct 
key or password.  

Starting with this advanced method of security, an extremely flexible and comprehensive 
security system has been added to the M1 software. There are currently three security levels in 
the M1.  

13.1 SECURITY LEVELS 

The M1 Build software has the controls to configure the appropriate security settings for an M1 
project. Security levels define the type of security used. Each level is defined below.  

Off 

When security is turned off, there is no security available throughout the M1 system. There is no 
option to configure users or security in either M1 Build or M1 Tune. Anyone who connects to the 
M1 ECU will be able to logon, download, modify or view any objects in the Package.  

Basic 

Basic security allows for a security setup that is easy to implement and maintain, but doesn't 
have the flexibility of the advanced security.  

There are no configuration settings in build for the basic security method, it also has no security 
groups and no build users.  

With basic security, all configurations are done in the M1 Tune application. When M1 Tune is 
first started with Basic security, the security system is effectively turned off. M1 Tune configures 
only a Guest user at this time, which has no password, and has full access to the system. The 
Guest account is a permanent account that is always available with Basic security. However, by 
adding a new user, you can set the Guest account to have no privileges. Doing this will 
effectively cause the Guest account to have no access, and administrator rights will pass to your 
new user. Your new user can have either password or key authentication for additional security. 
There must always be one user who has administrator access, and the administrator has access 
to everything. There can be more than one administrator. Other users can have varying levels of 
access, options for security include:  

• Allow send firmware  

• Allow change password  

• Allow change workbooks  

• Allow change ECU name  

• Allow firmware send, or upgrade only  

• View, adjust or no access to the default security group  

• Configurable access to Adjust, View, Retrieval, Convert and Erase of the 8 log systems.  



 

 User Manual

SECURITY

 

Printed documents are not controlled Page 65 

Each normal user can have a combination of the above settings configured for them by the ECU 
administrator.  

13.1.1 Advanced 

The M1 Advanced security configuration is a comprehensive and flexible method of setting up 
engine management access control. The security configuration allows the application developer 
to break up access to a project so that individual people or groups have access to the items that 
they need, whilst others can have a different subset.  
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14 HELP 

In addition to this help, the following is provided:  

• Tune help  

This is only available from windows and dialogue boxes that display a Help button. Click the 
Help button to access.  

• Context Package Help  

Provides information on what particular items within the Package do, how they interact, and 
what are the appropriate values. To access this information, select the item that help is 
required for and press F1. The Help panel will fly out from the right hand side of the M1 Tune 
window and display the relevant information for the selected item. With the Help panel 
open, select other items to change the help focus.  

• Overall Package Help  

To see the Context Package Help in one overall structured view, select menu Help > 
Package Help. This will list the Package help for each function in a top to bottom tree 
structure. Select the Show Contents icon to ensure to see the tree view.  
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15 GLOSSARY 

Term Definition 

Calculations Blocks of functionality used to control different systems in the 
vehicle, for example, idle control, boost, gear shift Etc. 

Channels A value that is updated by the firmware only, and readable by the 
end user within the M1 Tune application. 

Component An element that is placed in a Worksheet and provides a 
customised view of tables, parameters and channels, for example, 
a gauge displaying oil pressure. 

Configuration A named collection of table and parameter values. 

Firmware The firmware can be considered to be the program that runs on 
the M1 ECU and is created by M1 Build. A firmware consists of:  

• Parameters  

• Tables  

• Channels  

• Calculations. 

Migrate The process of importing data from one Package into another 

Package A MoTeC M1 package is made up of a number of components. 
These components include:  

• Package details  

• System Image (Kernel)  

• Firmware  

• Log Setups  

• Security.  

Package Details The package details contain information used to describe a 
package. 

Parameters Represents a single value that can be adjusted by the end user 
within the M1 Tune application. 

Resources Allow the dynamic selection of I/O pins settings. 

System Image (Kernel) The MoTeC provided firmware that provides low level services to 
the running firmware. 

Tables Represent a sequence of values that can be adjusted by the end 
user within the M1 Tune application. A table can be represented as 
a function of 1, 2, or 3 axes. 
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Term Definition 

Workbook Within a Workspace in M1 Tune, there can be a number of 
Workbooks. The Workbook is a method of grouping similar 
worksheets together. 

Worksheet The individual page or window that is used to contain components 
and gauges for the end user. 

Workspace Name given to the entire collection of M1 Tune layout and setting 
information. 
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16 KEYBOARD SHORTCUTS 

Keyboard shortcuts are available as described below.  
 

M1 Tune Section Description 

M1 Tune general These are shortcuts that perform high level general functions across 
M1 Tune. 

Components common These are shortcuts that perform common functions within any 
component. 

Table component These are shortcuts that perform specific functions in the table 
component. 

Parameter List 
component  

These are shortcuts that perform specific functions in the Parameter 
List component. 

Time Graph component  
These are shortcuts that perform specific functions in the Time 
Graph component. 
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16.1 M1 TUNE - GENERAL KEYBOARD SHORTCUTS 
 

Function  Shortcut  

Close Dock Window  [Esc]  

Compare Mode  [F4]  

Edit Comment...  [Ctrl+E]  

Get Logged Data...  [Ctrl+F8]  

Layout Editor...  [Ctrl+F7]  

Next Workbook  [Ctrl+F12]  

Next Worksheet  [Ctrl+Tab]  

Next Worksheet  [F12]  

Open ECU...  [F8]  

Open Package...  [Ctrl+O]  

Previous Workbook  [Ctrl+F11]  

Previous Worksheet  [F11]  

Print...  [Ctrl+P]  

Recent Workbook  [Ctrl+F10]  

Recent Worksheet  [F10]  

Redo  [Ctrl+Y]  

Save  [Ctrl+S]  

Show Channels  [C]  

Show Help  [F1]  

Show Invalid Data Summary...  [F7]  

Show Measurements  [M]  

Show Status...  [F3]  

Hold / Unhold Data Acquisition  [T]  

Undo  [Ctrl+Z]  
 



 

 User Manual

KEYBOARD SHORTCUTS

 

Printed documents are not controlled Page 71 

16.2 COMPONENTS - COMMON KEYBOARD SHORTCUTS 
 

Function  Shortcut  

Channel Properties...  [Ctrl+N]  

Copy  [Ctrl+Shift+C]  

Cut  [Ctrl+Shift+X]  

Hide All Color Bands  [Alt+Page Down]  

Hide Channel  [Ctrl+H]  

Maximise  [F6]  

Move Cursor Left  [Left]  

Move Cursor Right  [Right]  

Navigate Next  [Tab]  

Navigate Previous  [Shift+Tab]  

Paste  [Ctrl+Shift+V]  

Properties...  [F5]  

Channel Properties...  [Ctrl+N]  

Remove Item  [Ctrl+Delete]  

Show All Color Bands  [Alt+Page Up]  

Show Values  [V]  

Toggle Legend  [L]  

Undo Delete  [Ctrl+Shift+Z]  
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16.3 TABLE COMPONENT - KEYBOARD SHORTCUTS 
 

Function  Shortcut  

Calibrate  [Q]  

Calibrate (Copy Next Site)  [W]  

Clear Ramp Run  [Ctrl+R]  

Copy Data  [Ctrl+C]  

Cycle View Layout  [G]  

Decrement Value  [Page Down]  

Decrement Value Fast  [Ctrl+Page Down]  

Decrement Value Slow  [Shift+Page Down]  

Increment Value  [Page Up]  

Increment Value Fast  [Ctrl+Page Up]  

Increment Value Slow  [Shift+Page Up]  

Interpolate  [I]  

Jump to Operating Site  [Space]  

Next Table  [Alt+F12]  

Paste Data  [Ctrl+V]  

Previous Table  [Alt+F11]  

Recent Table  [Alt+F10]  

Reset Graph  [Home]  

Rotate Graph Anticlockwise  [Ctrl+Right]  

Rotate Graph Clockwise  [Ctrl+Left]  

Scale/Offset  [=]  

Select All  [Ctrl+A]  

Select Down  [Shift+Down]  

Select Left  [Shift+Left]  

Select Right  [Shift+Right]  
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Function  Shortcut  

Select Up  [Shift+Up]  

Setup Axis...  [A]  

Show Tables  [Esc]  

Start/Stop Ramp Run  [R]  

Swap Orientation  [Shift+G]  

Tag Value  [Backspace]  

Tilt Graph Back  [Ctrl+Up]  

Tilt Graph Forward  [Ctrl+Down]  

Untag Value  [Delete]  

X Axis Descending  [X]  

Y Axis Descending  [Y]  

Zero Value  [Z]  

Zoom Graph In  [+]  

Zoom Graph Out  [-]  
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16.4 PARAMETER LIST COMPONENT - KEYBOARD SHORTCUTS 
 

Function  Shortcut  

Calibrate  [Q]  

Calibrate All  Ctrl+Q]  

Copy Data  [Ctrl+C]  

Decrement Value  [Page Down]  

Decrement Value Fast  [Ctrl+Page Down]  

Decrement Value Slow  [Shift+Page Down]  

Increment Value  [Page Up]  

Increment Value Fast  [Ctrl+Page Up]  

Increment Value Slow  [Shift+Page Up]  

Paste Data  [Ctrl+V]  

Scale/Offset  [=]  

Show Grouped  [Shift+L]  

Swap Orientation  [Shift+G]  

Tag Value  [Backspace]  

Untag Value  [Delete]  

Zero Value  [Z]  
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16.5 TIME GRAPH COMPONENT - KEYBOARD SHORTCUTS 
 

Function  Shortcut  

AutoScale  [Ctrl+A]  

Center On Cursor  [H]  

Cursor Left  [Left]  

Cursor Right  [Right]  

Cycle Cursor Style  [Y]  

Overlapped Groups  [G]  

Fast Cursor Left  [Ctrl+Left]  

Fast Cursor Right  [Ctrl+Right]  

Horizontal Zoom Default  [W]  

Horizontal Zoom Full Out  [F2]  

Horizontal Zoom In  [Up]  

Horizontal Zoom Out  [Down]  

Jump Cursor End  [End]  

Jump Cursor Start  [Home]  

Next Channel  [Page Down]  

Pan Down  [Shift+Down]  

Pan Left  [Shift+Left]  

Pan Left (i1)  [B]  

Pan Right  [Shift+Right]  

Pan Right (i1)  [F]  

Pan Up  [Shift+Up]  

Place Datum Cursor  [Space]  

Previous Channel  [Page Up]  

Show Datum Cursor  [D]  

Show Status/Errors  [E]  



 

 User Manual

KEYBOARD SHORTCUTS

 

Printed documents are not controlled Page 76 

Function  Shortcut  

Swap Cursors  [X]  

Toggle Trace Style  [S]  

Vertical Zoom Full Out  [Alt+F2]  

Vertical Zoom In  [Alt+Up]  

Vertical Zoom Out  [Alt+Down]  

Zoom to Cursors  [Z]  
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