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T2 Telemetry Quick Start Guide 

About this Guide 
The aim of this guide is to provide basic instructions to get T2 Telemetry working end-to-end. The possible variations, 

and the flexibility built into the system, are not covered. 
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T2 Telemetry Quick Start System Requirements
 

System Requirements  
T2 Telemetry (T2) requires the following hardware and software. 

Hardware 
• ADL3 or C185 Data Logger with the T2 function upgrade enabled.  
• Radio or GSM modem with RS232 connection to the PC. Hardware used for the existing MoTeC Telemetry 

system is also supported.  

Software 
• ADL3 or C185 Dash Manager version 5.5 and later  
• i2 Pro Analysis version 1.1 and later  
• T2 server, version 1.1 and later 

Computer 
• Operating system: Microsoft Windows Vista or above.  

Note: Windows XP and earlier versions are not supported 
• Screen resolution: 1366 x 768 or greater  
• Browser: Internet Explorer 9 (minimum), 10 or above recommended 

Other Requirements 
• Administrator privileges are required for installation  
• Any active firewalls may need to be updated to allow the following for both T2 and i2: 

o Inbound and Outbound Multicast DNS traffic (IPv6) on UPD port 5353  
o Inbound HTTP traffic (IPv6) on TCP port 8888 
o Outbound Multicast UDP (IPv6) traffic from T2.exe 

• MoTeC i2 1.1 or higher is required for data analysis. 

Firewall Settings 
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T2 Telemetry Quick Start Overview of T2 Telemetry
 

Overview of T2 Telemetry 
This is a simplified overview of T2 Telemetry requirements and function. 

Figure 1. T2 Telemetry Overview 
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T2 Telemetry Quick Start Dash Manager Setup
 

Dash Manager Setup 

Communications Setup 
Note: The T2 function upgrade must be enabled for the Data Logger to send telemetry data.  

Current RS232 communication templates Telemetry Only or GPS & Telemetry can be used with T2.  

To setup communications: 

1. Go to the Connections > Communications menu. 
2. In the Communicators Setup window, select an RS232 tab. 
3. Set the applicable baud rate for the selected RS232 port. 
4. Select OK. 

Figure 2. Example Communications Setup  
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T2 Telemetry Quick Start Dash Manager Setup
 

Channel Setup 
Select the channels to be included in the telemetry stream. To do so: 

1. Select the Functions > Telemetry menu. 
2. In the Telemetry Server field, select MoTeC T2.  

Real Time tab 

1. In the Real Time tab, select Add and select channels to include in the telemetry stream. 

Figure 3. Example channel selection the Real Time tab 

 

Tab buttons Function 

Add  Add channel(s) to the T2 stream. Channels are added with default rate.  

Change  Change T2 channel properties: Rate, Group and Filter. 

Remove  Remove the selected channel(s) from the list. 

Remove All  Remove all channels from the list. 

Save As  Save the T2 setup to a file. 

Load  Load the T2 setup from a previously saved setup file. 

Percentage of the RS232 bandwidth occupied by the selected channels.  Bandwidth Utilization 

 

2. If the properties of any of the channel need to be altered: 

a. Select the channel. 
b. Select the Change button.  
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T2 Telemetry Quick Start Dash Manager Setup
 

Figure 4. Example Channel Properties 

 

Channel property Function 

Rate The rate at which a sample of the channel is included in the telemetry stream. 

Group Arrange channels in groups. This allows group filtering when setting up the T2 server.

Filter If the Rate is slower than the channel's sampling rate, filters can be applied so that the 
telemetry sample will have the minimum, maximum or average value over the previous 
sampling interval.

Alias A channel can be sent over telemetry with the option to have it display a different name 
and unit.  Figure 4 shows G Force Lat being sent with the alias of Lateral Accel. 

 

Parameters tab 

Use the Parameters tab to add any modem initialisation parameters. 
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T2 Telemetry Quick Start Dash Manager Setup
 

Security tab 

Used to enable encryption of the telemetry stream and/or set a new Salt. 

Encrypted telemetry data needs to be decrypted in the T2 server and/or in i2 Pro Analysis. Two encryption and 
decrypt/authentication methods are provided, password-based and key-based. 

Figure 5. Example Security Screen 

 

Channel property Function 

Name This is the username that is associated with either the password or key authentication. 

Salt About Salt 
Security must be enabled to create a Salt. 

A Salt is a set of encrypted bytes that are part of the telemetry metadata. It is used to 
match a telemetry data stream with a given configuration downstream (a T2 server, i2 
etc.).  

If security is enabled, and this is a completely new configuration, or the configuration has 
never had a Salt, then a Salt is automatically generated; this is the only time a Salt is 
automatically generated. 

An existing Salt can only be replaced manually; otherwise, the original Salt remains. A 
new Salt is generated by selecting the Generate New Salt button.  

If a new Salt is generated, the metadata file (which will contain the new Salt) must be 
provided downstream; otherwise, the stream will not be usable by a T2 server or i2. 

Note: If a Salt does not exist, correct matching between the data stream and the 
configuration must be manually managed by the user/team. 
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T2 Telemetry Quick Start Dash Manager Setup
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Channel property Function 

Password based 
authentication 

Specify the password with which to encrypt and decrypt the telemetry stream. The 
password must be provided to downstream users of the telemetry data. 

Key-based 
authentication 

A public key is required to encrypt the data; this can be created using the Create button or 
imported using the Import button. 

If imported, the matching private key needs to be available downstream to those who 
need to decrypt and access the data. 

If the Create button is used both a private and public key is produced. The private key 
should then be made available downstream as required to decrypt the data. 



T2 Telemetry Quick Start T2 Server Setup
 

T2 Server Setup 

Create Telemetry Configuration 
In T2 Server, a telemetry configuration contains one or more Telemetry Items, and optionally Security information. A 
Telemetry Item configures Input and Output Stream parameters. 

The Input stream identifies the origin of the telemetry data. The output stream(s) identify the destination of the 
telemetry data. A Telemetry Item contains one input stream and one or more output streams. 

To create a new Telemetry configuration: 

1. Select the File > New menu option.  

Figure 6. Telemetry Configuration  

 

2. Select the Add Item... button to setup a new Telemetry item. The Telemetry Item properties dialogue displays.  

Figure 7. Telemetry Item screen  

 

3. Compete the following details in each tab and screen as follows.  
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T2 Telemetry Quick Start T2 Server Setup
 

Tab or Screen  Tab or Screen Item  Setup 

General tab  Name field  Enter an identity, for example: Car 1. 

Input Stream tab 
specifies the input 
stream type.  

Data Source field  Select how T2 server is to receive its input, this can be from a serial 
port, network connection or replay of a saved image file or logged data.

Settings: Serial Port 
selection  

The telemetry input stream comes from a radio or GSM modem. The 
Serial Port Settings should be set according to the COM port that 
receives the telemetry stream and according to the RS232 parameters 
in the modem. 

Figure 8a. Example Serial Port Input Source  

 

Settings: 
Network selection 

If the telemetry input stream comes from a network device, (RS232 to 
UDP or the car radio itself), these devices need to be configured to push 
their data to an IP address and a port number. 

Example shown in figure 8b has the incoming data on IP 192.168.0.187 
and a port number of 6001, The radio device sending the data has a 
fixed IP address of 192.168.0.191.  

Entering this IP in the Diagnostics section will aid diagnosis of a 
connection by allowing the main details tab of T2 to show a ping 
response from the device (see figure 8c).  

Figure 8b. Example Network Input Source 
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T2 Telemetry Quick Start T2 Server Setup
 

Figure 8c. Example Network Input Source with Ping test 

 

 

Settings : Save the 
telemetry image 
 

On the Input tab, under the Data source type is a tick box Save Input 
data for Playback (see Figure 8b). When this box is ticked T2 will record 
the incoming telemetry data stream so that the user can  replay it at a 
later time.  T2 telemetery images can be found in 
C:\ProgramData\MoTeC\T2\Image. 

 

Settings: Image Play 
back selection 

Selecting the Data Source Type as MoTeC T2 Image file, will allow the 
user to replay a recorded telemetry session. 

Figure 8d 

 

When a telemetry image is setup and that car or input is selected, the 
controls for playing/stopping are displayed on the main T2 display., 
Figure 8e shows an input named replay that is setup and selected, 
displaying the controls on the right hand side. 

Figure 8e 
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T2 Telemetry Quick Start T2 Server Setup
 

Output Stream tab 
allows creation of 
a number of 
output streams. 
The telemetry data 
can be transmitted 
(streamed) over 
different network 
connections, 
saved to an image 
file or accessed 
via the T2 Server 
API.  

Add button  Adds a new output stream. The Output Stream Properties dialogue 
displays, and is used to configure the stream.  

Figure 9. Output Stream Properties  

  

MoTeC — Published: 9 June 2015 Page 12 



T2 Telemetry Quick Start T2 Server Setup
 

Output Stream 
Properties screen  

Name field  Enter a name for the output stream. 

Export: T2 Server 
(Network 
(Multicast)  

The data is streamed over the network. A specific network card 
(interface) can be selected. Default is sending the data to All Interfaces. 
If the Save output data… checkbox is checked, the output data is also 
saved to a backup file while T2 Server is running. When the T2 Server 
application is closed, the backup file is deleted. The Save output option 
allows downstream clients to request data. For example, i2 allows data 
to be retrieved and loaded as a Log File.

Export: T2 API  Allows T2 Telemetry stream to be used with the T2 Server API (not 
covered in this guide). 

Security: Decrypt... 
checkbox  

If telemetry stream was encrypted in the Data Logger, it can be 
decrypted in T2 Server and sent to the output as non-encrypted. 
Decryption is done using Security Items. If Auto is selected from the 
drop down menu, T2 will search through all configured security items 
looking for a match. The user can select from this menu a security item 
to use that only decrypts the incoming stream for that input (if it 
matches what is selected). 

Security: Encrypt... 
checkbox  

  

The output stream can be encrypted using a Security Item. To create a 
new Security Item, select the [+] button.  See Security. 
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T2 Telemetry Quick Start T2 Server Setup
 

Security 
The Security toolbar button allows creation of a number of Security Items.  

A Security Item is a Name and Password or Key pair that can be applied to an input or an output stream.  

Note: If security has been applied to the input stream (that is, the telemetry stream is encrypted in the Data Logger), 
the T2 Server Security screen will show the names of the security items applied to the input streams. The Password 
has to be provided for the input stream to be decrypted. 

Figure 10. Example Security Screen  
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T2 Telemetry Quick Start T2 Server Setup
 

T2 Server - Confirming Telemetry Configuration Setup 
If T2 Server and Telemetry Item(s) are configured correctly, the Telemetry Item will be green and the packet counters 
will show packets coming in and going out. The graph will give an indication of data coming in and going out via the 
outputs. If there is a fault, the Input or Output boxes will go red and an error message will display to highlight where 
the possible fault may lie. See figure 10 above where the security password has not been entered, preventing the 
output going green). 

To view Telemetry Item details, use the Details screen. Select Enable Live Update checkbox to allow viewing the raw 
RS232 input stream; however, we recommend it only be used for diagnostics purposes, and otherwise left disabled. 

Figure 11. Example Active Telemetry Stream  

 

Figure 12. Example Active Telemetry Stream  

The example below shows 4 cars configured in the same T2 Server. The example shows cars 1 and 4 connected. Car 
4 is setup to go to multiple sources with active filters (to limit what the source has available to view in i2 Pro). 
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T2 Telemetry Quick Start T2 Server Setup
 

Using Alias Names in T2 Server for API output 
If a channel has been sent over telemetry with an Alias configured as outlined on page 6, and you want to use this 
name in the T2 API output, select Tools > Options from the T2 menu, 

On the Options Tab (figure 13a) select the option Use alternative names & units 

Figure 13a. T2 Server Options box 

 

Using Alias Names in i2 Pro  
If a channel has been sent over telemetry with an Alias configured as outlined on page 6, and you want to use this 
name in i2 as the name of the channel, select Tools > Options from the i2 menu, 

In the Options box (figure 13b), click on the Telemetry Tab and select the option Use alternative names & units  

Figure 13b. i2 Pro Options box 

 

If Use alternative names and units is not selected in either T2 or i2Pro, the standard channel name is used. 
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T2 Telemetry Quick Start i2 Pro Analysis
 

i2 Pro Analysis 

i2 T2 Telemetry Setup 
The streamed telemetry data can be viewed live in i2 as follows. 

1. Select File > Telemetry menu item to display the Telemetry screen.  
2. Check the Enable Telemetry checkbox.  
3. Ensure T2 Server is configured and running.  
4. Select the Add button.  

All the T2 Server and Telemetry Items available on the network are listed in the Select Telemetry Server(s) 
screen. 

Figure 14. Telemetry Setup  

 

5. Select the required Telemetry Server and associated Telemetry Item from the list.  

In the example above two T2 Servers and Telemetry Items are listed. For the first, the breakup of the name is as 
follows: 

COMBINE  ADL3 15006  Bench 
T2Server  Telemetry Item name Output Stream name 

The selected T2 source name will appear in the Configured Telemetry Sources list.  
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T2 Telemetry Quick Start i2 Pro Analysis
 

Figure 15. Example Configured Telemetry Sources List with Receive Timeout 

 

If the T2 Source Status remains as Connecting or Timed Out make sure that your antivirus and firewall 
configuration settings are correct. See System Requirements.  

Note: Telemetry Source Status of Receive Pending indicates that the telemetry stream is encrypted.  

6. To decrypt the telemetry stream, select the Security button.  
7. Select the relevant Security Item, select the Edit button and enter the password. This same screen is used to 

create Security Items, for example if the Item required does not exist in the list. See Security. 
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T2 Telemetry Quick Start i2 Pro Analysis
 

Figure 16. Security Example  

 

When i2 Pro Analysis receives a valid telemetry stream, the Telemetry Source Status indicator changes to 
Running. 

Figure 17. Example of a Telemetry Steam with a Running Status 
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T2 Telemetry Quick Start i2 Pro Analysis
 

8. Use the Track Map drop-down list to select a track map associated with the telemetry source.  

Track maps (*.mt2 files) must be located in the Track Maps folder of the i2 Pro Analysis workspace.  

The Remove, Edit, and Security buttons on the Telemetry screen perform the following function.  

Button  Function 

Remove  Removes the selected Telemetry Source from the list. 

Edit  Opens the Edit Telemetry Server screen.  
 

Figure 18. Example Edit Telemetry Server Screen  

 

The following function apply to these items on the Edit Telemetry Server screen: 
• Show in the 'Data' window checkbox  

De-selecting disables the Telemetry Source.  
• Telemetry Track Map Colour selector  

Sets the Telemetry Track Map Position colour.  
• DDE checkbox  

Selecting enables sending telemetry data over DDE.  
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T2 Telemetry Quick Start i2 Pro Analysis
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Button  Function 

Security  Allows a Security Item to be added, removed, imported from or exported to a file. 
A public key can only encrypt an output stream, A private key can both encrypt and decrypt. If the main 
server is setup to encrypt with a public key, then the private key (for decryption) will be required for the 
second T2 server or I2 setup. 
 

Figure 19. Example Security Screen  

 
 

 

  



T2 Telemetry Quick Start i2 Pro Analysis
 

i2 Telemetry Functions 

Add menu 

Allows addition of the following items:  

Add > Telemetry > Track Position  

Add > Telemetry > GPS Track  

Add > Telemetry > Web View  

If the computer has an internet connection, the Web View element allows the display of web page content.  

Options menu 

Tools > Options – telemetry options can be set in the Telemetry tab.  

Math Channels 

In telemetry mode, Math Channels can calculate their values live. To do this, in the Math Expressions Editor, select 
the Apply to: Telemetry checkbox.  

Figure 20. Example Maths Expression Editor  
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T2 Telemetry Quick Start i2 Pro Analysis
 

Alarms 

Create alarms using the Tools > Alarms menu.  

In the example below, the following alarm is created.  

Timed alarms: ('Engine RPM' > 6500) for 2[s]  

Figure 21. Example of Alarm Creation  
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T2 Telemetry Quick Start i2 Pro Analysis
 

When an alarm is active, the alarm name will flash at the bottom of i2 Pro Analysis screen. Click on the indicator or 
press [F3] to open the Alarms popup window; from where they can be viewed and acknowledged.  

Figure 22. Example Alarm  
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T2 Telemetry Quick Start Supplementary Information
 

Supplementary Information 

Metadata File 
When a Data Logger configuration file that includes T2 Telemetry setup is sent to the Data Logger, a Metadata file is 
created. This file is essential for T2 to operate. 

Note: When Dash Manger and T2 Server are running on the same PC, and using the default location for the Metadata 
file, no intervention is required and access to the file is automatic. 

MetaData Location 

Dash Manager 

By default, the Metadata file is saved in the C:\ProgramData\MoTeC\T2\MetaData folder of the Dash Manager PC. 

To specify a different location: in Dash Manager Tools > Options menu Telemetry tab, specify the required location. 

T2 Server 

To receive and transmit telemetry data, the T2 server requires the Metadata file to be located in the 
C:\ProgramData\MoTeC\T2\MetaData folder on the PC that runs T2 Server.  

T2 Server can be set up to automatically pull and copy the file to this location as follows: 

1. In T2 Server, go to the Tools > Options menu Folders tab and specify the remote location for T2 Server to search. 
2. Select the Add button to specify other locations. 

As each Metadata file has a unique identifier, T2 server monitors all specified locations and pulls the Metadata 
file once it is available.Figure 23. Example Dialogue for Specifying Metadata File Locations
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Frequently Asked Questions 
Question Remedy

The input Stream is green and 
I have data coming in, but the 
Output stream is Red? 

On the configured output, check the network output is selected and available. The 
Network Adaptor will only be available for selection when it has an active link. 
 
If running security, click on Security and check the password is correct. 

T2 asks for a password when I 
open the application? 

If the saved configuration has any security setup, it will ask for a master password 
upon closing for the first time and opening, This password encrypts the 
configuration so that the Security tab cannot be accessed by anyone without the 
master password. This eliminates the user setting the passwords or loading keys 
each time the configuration is loaded.

T2 Server has green 
input/outputs, but I can’t 
connect i2 on another machine 
located on the same network? 

If the PC is connected to the network via a router, check that the router is 
configured to allow multicasting to be passed through. 

i2 can see a Telemetry Source 
from the T2 Server but the 
data won’t scroll in? 

Once a telemetry source is added, check what is being shown in the status 
column. See examples below. 
 

 
In this example it won’t connect due to the stream being encrypted. If this occurs, 

click on the security tab at the bottom to rectify. 
 

 
In this example, check the T2 server still has a valid input, check antivirus and 

firewall settings are correct. 
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Question Remedy

 

 
If i2 status stays at connecting, check antivirus and firewall settings. 
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